CVE-2022-2230 Cross-site scripting in GitLab

High 8.1 Published Updated

An attacker can execute arbitrary JavaScript in GitLab via stored XSS in project settings, potentially compromising user accounts.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-2230?

CVE-2022-2230 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 1 Jul 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A Stored Cross-Site Scripting vulnerability in the project settings page in GitLab CE/EE affecting all versions from 14.4 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1, allows an attacker to execute arbitrary JavaScript code in GitLab on a victim's behalf.

Weakness: CWE-79

Which versions are affected by CVE-2022-2230?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.4.014.10.5, 15.0.4, 15.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2230?

Upgrade gitlab to a fixed version for your release line: 14.10.5, 15.0.4 or 15.1.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-2230 being exploited?

There is no known exploitation of CVE-2022-2230 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2230, GHSA-q874-xrmj-fh8q, UBUNTU-CVE-2022-2230.

Is CVE-2022-2230 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free