CVE-2022-2235 Cross-site scripting in GitLab

High 8.7 Published Updated

An attacker can execute arbitrary scripts in a victim's browser via a malicious ZenTao link in GitLab EE's external issue tracker.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-2235?

CVE-2022-2235 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 1 Jul 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Insufficient sanitization in GitLab EE's external issue tracker affecting all versions from 14.5 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 allows an attacker to perform cross-site scripting when a victim clicks on a maliciously crafted ZenTao link

Weakness: CWE-79

Which versions are affected by CVE-2022-2235?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.5.014.10.5, 15.0.4, 15.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2235?

Upgrade gitlab to a fixed version for your release line: 14.10.5, 15.0.4 or 15.1.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-2235 being exploited?

There is no known exploitation of CVE-2022-2235 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2235, GHSA-mxgw-4fpv-6f32, UBUNTU-CVE-2022-2235.

Is CVE-2022-2235 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free