CVE-2022-2243 Missing authorization in GitLab

Medium 5.0 Published Updated

Authenticated users can enumerate issues in non-linked Sentry projects due to missing authorization checks in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-2243?

CVE-2022-2243 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 1 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An access control vulnerability in GitLab EE/CE affecting all versions from 14.8 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1, allows authenticated users to enumerate issues in non-linked sentry projects.

Weakness: CWE-639

Which versions are affected by CVE-2022-2243?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.8.014.10.5, 15.0.4, 15.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2243?

Upgrade gitlab to a fixed version for your release line: 14.10.5, 15.0.4 or 15.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-2243 being exploited?

There is no known exploitation of CVE-2022-2243 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2243, GHSA-jg7h-cr7w-5fc6, UBUNTU-CVE-2022-2243.

Is CVE-2022-2243 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free