CVE-2022-2244 Missing authorization in GitLab
Project members with reporter role can improperly manage issues in the error tracking feature due to missing authorization checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-2244?
CVE-2022-2244 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 1 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An improper authorization vulnerability in GitLab EE/CE affecting all versions from 14.8 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1, allows project memebers with reporter role to manage issues in project's error tracking feature.
Which versions are affected by CVE-2022-2244?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 14.8.0 | 14.10.5, 15.0.4, 15.1.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-2244?
Upgrade gitlab to a fixed version for your release line: 14.10.5, 15.0.4 or 15.1.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-2244 being exploited?
There is no known exploitation of CVE-2022-2244 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-2244, GHSA-4wc6-q22j-fx9w, UBUNTU-CVE-2022-2244.