# CVE-2022-2256: Keycloak vulnerable to Stored Cross site Scripting (XSS) when loading default roles

> A privileged attacker can execute malicious scripts in the Keycloak admin console via stored XSS in default roles, potentially compromising administrative accounts.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-w9mf-83w3-fv49

## What is CVE-2022-2256?

CVE-2022-2256 is a low-severity cross-site scripting vulnerability in Redhat Single Sign-On, published on 1 Sep 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A Stored Cross-site scripting (XSS) vulnerability was found in keycloak as shipped in Red Hat Single Sign-On 7. This flaw allows a privileged attacker to execute malicious scripts in the admin console, abusing the default roles functionality.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-2256?

2 open source packages ship an affected version, including org.keycloak:keycloak-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-parent` | Maven | All versions | 19.0.2 |
| `org.keycloak:keycloak-parent` | Maven | All versions | 19.0.2 |

Products: Redhat Single Sign-On.

## How do I fix CVE-2022-2256?

Upgrade org.keycloak:keycloak-parent to 19.0.2 or later.

## Is CVE-2022-2256 being exploited?

There is no known exploitation of CVE-2022-2256 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Single Sign-On

- [CVE-2020-10695](https://insights.sbomify.com/CVE-2020-10695/): Privilege escalation in containers/redhat-sso-7 (high 7.8)
- [CVE-2021-3424](https://insights.sbomify.com/CVE-2021-3424/): Keycloak is vulnerable to IDN homograph attack (medium 5.3)
- [CVE-2020-14341](https://insights.sbomify.com/CVE-2020-14341/): Server-side request forgery in Red Hat Single Sign-On (low 2.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2256 and fix it if it is affected.

What it is: CVE-2022-2256 is a low-severity cross-site scripting vulnerability in Redhat Single Sign-On, published on 1 Sep 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2256 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-parent (Maven): affected all versions; fixed in 19.0.2
- org.keycloak:keycloak-parent (Maven): affected all versions; fixed in 19.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2256/ (Markdown: https://insights.sbomify.com/CVE-2022-2256/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2256
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2256
- OSV: https://osv.dev/vulnerability/CVE-2022-2256

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2256/
Summaries are generated and may contain mistakes; the official description above is the record.
