CVE-2022-22570 Memory corruption in UniFi Door Access Reader Lite

Critical 10.0 Published Updated

A buffer overflow in UniFi Door Access Reader Lite firmware allows network attackers to control connected devices, requiring a firmware upgrade.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2022-22570?

CVE-2022-22570 is a critical memory corruption vulnerability in UniFi Door Access Reader Lite, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A buffer overflow vulnerability found in the UniFi Door Access Reader Lite’s (UA Lite) firmware (Version 3.8.28.24 and earlier) allows a malicious actor who has gained access to a network to control all connected UA devices. This vulnerability is fixed in Version 3.8.31.13 and later.

Weakness: CWE-120

Which versions are affected by CVE-2022-22570?

It affects 1 product.

Products include Ui Ua Lite Firmware.

How do I fix CVE-2022-22570?

No fix has been published for CVE-2022-22570 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2022-22570 being exploited?

There is no known exploitation of CVE-2022-22570 in the wild and no public exploit code.

Sources

Also known as GHSA-qc3q-358p-q5mv.

Is CVE-2022-22570 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free