# CVE-2022-22570: Memory corruption in UniFi Door Access Reader Lite

> A buffer overflow in UniFi Door Access Reader Lite firmware allows network attackers to control connected devices, requiring a firmware upgrade.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-qc3q-358p-q5mv

## What is CVE-2022-22570?

CVE-2022-22570 is a critical memory corruption vulnerability in UniFi Door Access Reader Lite, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A buffer overflow vulnerability found in the UniFi Door Access Reader Lite’s (UA Lite) firmware (Version 3.8.28.24 and earlier) allows a malicious actor who has gained access to a network to control all connected UA devices. This vulnerability is fixed in Version 3.8.31.13 and later.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2022-22570?

It affects 1 product.


Products: Ui Ua Lite Firmware.

## How do I fix CVE-2022-22570?

No fix has been published for CVE-2022-22570 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-22570 being exploited?

There is no known exploitation of CVE-2022-22570 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22570 and fix it if it is affected.

What it is: CVE-2022-22570 is a critical memory corruption vulnerability in UniFi Door Access Reader Lite, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22570 in the wild and no public exploit code.

Affected product: UniFi Door Access Reader Lite. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22570/ (Markdown: https://insights.sbomify.com/CVE-2022-22570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22570
- OSV: https://osv.dev/vulnerability/CVE-2022-22570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22570/
Summaries are generated and may contain mistakes; the official description above is the record.
