CVE-2022-22577 Cross-site Scripting Vulnerability in Action Pack
An XSS vulnerability in Action Pack allows attackers to bypass Content Security Policy for non-HTML responses, affecting Ruby on Rails applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-22577?
CVE-2022-22577 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 26 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An XSS Vulnerability in Action Pack >= 5.2.0 and < 5.2.0 that could allow an attacker to bypass CSP for non HTML like responses.
Weakness: CWE-79
Which versions are affected by CVE-2022-22577?
8 open source packages ship an affected version, including actionpack. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
actionpack RubyGems | From 5.2.0 | 5.2.7.1 |
actionpack RubyGems | From 5.2.0 | 5.2.7.1 |
actionpack RubyGems | From 6.0.0 | 6.0.4.8 |
actionpack RubyGems | From 6.0.0 | 6.0.4.8 |
actionpack RubyGems | From 6.1.0 | 6.1.5.1 |
actionpack RubyGems | From 6.1.0 | 6.1.5.1 |
2 more packages
actionpack RubyGems | From 7.0.0 | 7.0.2.4 |
actionpack RubyGems | From 7.0.0 | 7.0.2.4 |
Products include Debian Debian Linux, Rubyonrails Actionpack.
How do I fix CVE-2022-22577?
Upgrade actionpack to a fixed version for your release line: 5.2.7.1, 6.0.4.8, 6.1.5.1 or 7.0.2.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-22577 being exploited?
There is no known exploitation of CVE-2022-22577 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2022-22577, GHSA-mm33-5vfq-3mm3, UBUNTU-CVE-2022-22577.