CVE-2022-2270 Information disclosure in GitLab
GitLab leaks Conan package names due to incorrect permission checks, allowing attackers to view private package information.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-2270?
CVE-2022-2270 is a low-severity vulnerability in Gitlab Gitlab, published on 1 Jul 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An issue has been discovered in GitLab affecting all versions starting from 12.4 before 14.10.5, all versions starting from 15.0 before 15.0.4, all versions starting from 15.1 before 15.1.1. GitLab was leaking Conan packages names due to incorrect permissions verification.
Weakness: CWE-276
Which versions are affected by CVE-2022-2270?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.4.0 | 14.10.5, 15.0.4, 15.1.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-2270?
Upgrade gitlab to a fixed version for your release line: 14.10.5, 15.0.4 or 15.1.1.
Is CVE-2022-2270 being exploited?
There is no known exploitation of CVE-2022-2270 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-2270, GHSA-64vr-2vhr-px3r, UBUNTU-CVE-2022-2270.