{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 7 products.","exploited":"There is no known exploitation of CVE-2022-22719 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.53 or later.","what":"CVE-2022-22719 is a high-severity vulnerability in Apache Http Server, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-22719 and fix it if it is affected.\n\nWhat it is: CVE-2022-22719 is a high-severity vulnerability in Apache Http Server, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-22719 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected all versions; fixed in 2.4.53\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-22719/ (Markdown: https://insights.sbomify.com/CVE-2022-22719/index.md)","id":"CVE-2022-22719","markdown":"https://insights.sbomify.com/CVE-2022-22719/index.md","name":"CVE-2022-22719","record":{"aliases":["ALPINE-CVE-2022-22719","AZL-9015","BIT-apache-2022-22719","CLEANSTART-2026-SY05950","DEBIAN-CVE-2022-22719","GHSA-2349-9g3v-jxmj","UBUNTU-CVE-2022-22719"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache HTTP Server","requires_auth":"none","summary":"A crafted request body in mod_lua causes a crash via uninitialized memory read, impacting Apache HTTP Server availability.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"},{"product":"mac_os_x","vendor":"apple"},{"product":"macos","vendor":"apple"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"http_server","vendor":"oracle"},{"product":"zfs_storage_appliance_kit","vendor":"oracle"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-665","name":"Improper Initialization"}],"description":"A carefully crafted request body can cause a read to a random memory area which could cause the process to crash. This issue affects Apache HTTP Server 2.4.52 and earlier.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"mod_lua Use of uninitialized value of in r:parsebody","id":"CVE-2022-22719","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server","apple:mac_os_x","apple:macos","debian:debian_linux","fedoraproject:fedora","oracle:http_server","oracle:zfs_storage_appliance_kit"],"type":"null_dereference","year":"2022"},"n_packages":1,"n_references":15,"next":{"headline":"HTTP request smuggling vulnerability in Apache HTTP Server 2.4.52 and earlier","id":"CVE-2022-22720"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.53"],"introduced":["0"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2022-22719"}],"prev":{"headline":"Microsoft Windows Print Spooler Privilege Escalation","id":"CVE-2022-22718"},"products":["Apache HTTP Server"],"published":"2022-03-14","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"A crafted request body in mod_lua causes a crash via uninitialized memory read, impacting Apache HTTP Server availability.","url":"https://insights.sbomify.com/CVE-2022-22719/"}