# CVE-2022-22721: core: Possible buffer overflow with very large or unlimited LimitXMLRequestBody

> An integer overflow in Apache HTTP Server on 32-bit systems can lead to out-of-bounds writes and potential code execution if LimitXMLRequestBody is set excessively high.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2022-22721, AZL-9017, BIT-apache-2022-22721, CLEANSTART-2026-UC87477, DEBIAN-CVE-2022-22721, GHSA-24r7-x8mx-hc2h, UBUNTU-CVE-2022-22721

## What is CVE-2022-22721?

CVE-2022-22721 is a critical vulnerability in Apache Http Server, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

If LimitXMLRequestBody is set to allow request bodies larger than 350MB (defaults to 1M) on 32 bit systems an integer overflow happens which later causes out of bounds writes. This issue affects Apache HTTP Server 2.4.52 and earlier.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2022-22721?

1 open source package ship an affected version, including apache. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | All versions | 2.4.53 |

Products: Apache Http Server, Apple Mac Os X, Apple Macos, Debian Debian Linux, Fedoraproject Fedora, Oracle Enterprise Manager Ops Center, Oracle Http Server, Oracle Zfs Storage Appliance Kit.

## How do I fix CVE-2022-22721?

Upgrade apache to 2.4.53 or later.

## Is CVE-2022-22721 being exploited?

There is no known exploitation of CVE-2022-22721 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22721 and fix it if it is affected.

What it is: CVE-2022-22721 is a critical vulnerability in Apache Http Server, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22721 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected all versions; fixed in 2.4.53

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22721/ (Markdown: https://insights.sbomify.com/CVE-2022-22721/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22721
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22721
- OSV: https://osv.dev/vulnerability/CVE-2022-22721

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22721/
Summaries are generated and may contain mistakes; the official description above is the record.
