{"answers":{"affected":"3 open source packages ship an affected version, including openssl-src. It affects 7 products.","exploited":"There is no known exploitation of CVE-2022-2274 in the wild and no public exploit code.","fix":"Upgrade openssl-src to 300.0.9 or later.","what":"CVE-2022-2274 is a critical memory corruption vulnerability in Netapp H300s Firmware, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-2274 and fix it if it is affected.\n\nWhat it is: CVE-2022-2274 is a critical memory corruption vulnerability in Netapp H300s Firmware, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-2274 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openssl-src (crates.io): affected from 300.0.8; fixed in 300.0.9\n- openssl-src (crates.io): affected from 300.0.8; fixed in 300.0.9\n- openssl-src (crates.io): affected from 300.0.8; fixed in 300.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2274/ (Markdown: https://insights.sbomify.com/CVE-2022-2274/index.md)","id":"CVE-2022-2274","markdown":"https://insights.sbomify.com/CVE-2022-2274/index.md","name":"CVE-2022-2274","record":{"aliases":["DEBIAN-CVE-2022-2274","GHSA-735f-pg76-fxc4","RUSTSEC-2022-0033","UBUNTU-CVE-2022-2274","openSUSE-SU-2024:12983-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenSSL cryptographic library","requires_auth":"none","summary":"A bug in OpenSSL's RSA implementation on AVX512IFMA CPUs causes memory corruption, potentially allowing remote code execution on affected servers.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openssl","cpe":[{"product":"h300s_firmware","vendor":"netapp"},{"product":"h410c_firmware","vendor":"netapp"},{"product":"h410s_firmware","vendor":"netapp"},{"product":"h500s_firmware","vendor":"netapp"},{"product":"h700s_firmware","vendor":"netapp"},{"product":"snapcenter","vendor":"netapp"},{"product":"openssl","vendor":"openssl"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"The OpenSSL 3.0.4 release introduced a serious bug in the RSA implementation for X86_64 CPUs supporting the AVX512IFMA instructions. This issue makes the RSA implementation with 2048 bit private keys incorrect on such machines and memory corruption will happen during the computation. As a consequence of the memory corruption an attacker may be able to trigger a remote code execution on the machine performing the computation. SSL/TLS servers or other servers using 2048 bit RSA private keys running on machines supporting AVX512IFMA instructions of the X86_64 architecture are affected by this issue.","ecosystems":["crates.io","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2022-09-24","github_poc":3,"max_poc_stars":16,"metasploit":0,"nuclei":0,"refs":[{"date":"2022-09-24T21:30:34Z","kind":"github_poc","ref":"https://github.com/Malwareman007/CVE-2022-2274","stars":16,"title":"A POC OF CVE-2022-2274 (openssl)"},{"date":"2022-11-11T16:27:45Z","kind":"github_poc","ref":"https://github.com/EkamSinghWalia/OpenSSL-Vulnerability-Detection-Script","stars":1,"title":"This is an OpenSSL Vulnerability Detection Script for CVE-2022-2274"},{"date":"2023-02-21T01:56:51Z","kind":"github_poc","ref":"https://github.com/DesmondSanctity/CVE-2022-2274","stars":1,"title":"OpenSSL-src Heap Memory Corruption with RSA Private Key Operation : CVE-2022-2274"}],"tier":"poc_unverified"},"has_fix":true,"headline":"RSA implementation bug in AVX512IFMA instructions","id":"CVE-2022-2274","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":"netapp:h300s_firmware","products":["netapp:h300s_firmware","netapp:h410c_firmware","netapp:h410s_firmware","netapp:h500s_firmware","netapp:h700s_firmware","netapp:snapcenter","openssl:openssl"],"type":"memory_corruption","year":"2022"},"n_packages":4,"n_references":4,"next":{"headline":"WP Edit Menu \u003c= 1.5.0 - Arbitrary Post Deletion via CSRF","id":"CVE-2022-2275"},"packages":[{"ecosystem":"crates.io","fixed":["300.0.9"],"introduced":["300.0.8"],"last_affected":[],"package":"openssl-src","purl":null,"source":"GHSA-735f-pg76-fxc4"},{"ecosystem":"crates.io","fixed":["300.0.9"],"introduced":["300.0.8"],"last_affected":[],"package":"openssl-src","purl":"pkg:cargo/openssl-src","source":"GHSA-735f-pg76-fxc4"},{"ecosystem":"crates.io","fixed":["300.0.9"],"introduced":["300.0.8"],"last_affected":[],"package":"openssl-src","purl":"pkg:cargo/openssl-src","source":"RUSTSEC-2022-0033"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["9.3p1-1.1"],"introduced":["0"],"last_affected":[],"package":"openssh","purl":"pkg:rpm/opensuse/openssh\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12983-1"}],"prev":{"headline":"Simple Membership \u003c 4.1.3 - Membership Privilege Escalation","id":"CVE-2022-2273"},"products":["OpenSSL"],"published":"2022-07-01","related":[{"cvss_score":9.1,"headline":"XML external entity in libxml2","id":"CVE-2024-40896","kev_date_added":null,"published":"2024-12-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-10-14","vendors":["OpenSSL"]},"summary":"A bug in OpenSSL's RSA implementation on AVX512IFMA CPUs causes memory corruption, potentially allowing remote code execution on affected servers.","url":"https://insights.sbomify.com/CVE-2022-2274/"}