# CVE-2022-2274: RSA implementation bug in AVX512IFMA instructions

> A bug in OpenSSL's RSA implementation on AVX512IFMA CPUs causes memory corruption, potentially allowing remote code execution on affected servers.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2022
- **Updated:** 14 Oct 2026
- **Also known as:** DEBIAN-CVE-2022-2274, GHSA-735f-pg76-fxc4, RUSTSEC-2022-0033, UBUNTU-CVE-2022-2274, openSUSE-SU-2024:12983-1

## What is CVE-2022-2274?

CVE-2022-2274 is a critical memory corruption vulnerability in Netapp H300s Firmware, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The OpenSSL 3.0.4 release introduced a serious bug in the RSA implementation for X86_64 CPUs supporting the AVX512IFMA instructions. This issue makes the RSA implementation with 2048 bit private keys incorrect on such machines and memory corruption will happen during the computation. As a consequence of the memory corruption an attacker may be able to trigger a remote code execution on the machine performing the computation. SSL/TLS servers or other servers using 2048 bit RSA private keys running on machines supporting AVX512IFMA instructions of the X86_64 architecture are affected by this issue.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2022-2274?

3 open source packages ship an affected version, including openssl-src. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 300.0.8 | 300.0.9 |
| `openssl-src` | crates.io | From 300.0.8 | 300.0.9 |
| `openssl-src` | crates.io | From 300.0.8 | 300.0.9 |
| `openssh` | openSUSE:Tumbleweed | All versions | 9.3p1-1.1 |

Products: Netapp H300s Firmware, Netapp H410c Firmware, Netapp H410s Firmware, Netapp H500s Firmware, Netapp H700s Firmware, Netapp Snapcenter, Openssl Openssl.

## How do I fix CVE-2022-2274?

Upgrade openssl-src to 300.0.9 or later.

## Is CVE-2022-2274 being exploited?

There is no known exploitation of CVE-2022-2274 in the wild and no public exploit code.

Public exploit code:

- A POC OF CVE-2022-2274 (openssl) (github_poc): https://github.com/Malwareman007/CVE-2022-2274
- This is an OpenSSL Vulnerability Detection Script for CVE-2022-2274 (github_poc): https://github.com/EkamSinghWalia/OpenSSL-Vulnerability-Detection-Script
- OpenSSL-src Heap Memory Corruption with RSA Private Key Operation : CVE-2022-2274 (github_poc): https://github.com/DesmondSanctity/CVE-2022-2274

## Other vulnerabilities in Netapp H300s Firmware

- [CVE-2024-40896](https://insights.sbomify.com/CVE-2024-40896/): XML external entity in libxml2 (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2274 and fix it if it is affected.

What it is: CVE-2022-2274 is a critical memory corruption vulnerability in Netapp H300s Firmware, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2274 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 300.0.8; fixed in 300.0.9
- openssl-src (crates.io): affected from 300.0.8; fixed in 300.0.9
- openssl-src (crates.io): affected from 300.0.8; fixed in 300.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2274/ (Markdown: https://insights.sbomify.com/CVE-2022-2274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2274
- OSV: https://osv.dev/vulnerability/CVE-2022-2274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2274/
Summaries are generated and may contain mistakes; the official description above is the record.
