# CVE-2022-22773: TIBCO JasperReports Server Reflected Cross Site Scripting (XSS) vulnerability

> A low-privileged attacker can execute scripts on the victim's system via reflected XSS in the REST API of TIBCO JasperReports Server.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 May 2022
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-jasperreports-2022-22773, GHSA-mf8h-5f5r-mpg8

## What is CVE-2022-22773?

CVE-2022-22773 is a high-severity cross-site scripting vulnerability in TIBCO JasperReports Server, published on 17 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The REST API component of TIBCO Software Inc.'s TIBCO JasperReports Server, TIBCO JasperReports Server - Community Edition, TIBCO JasperReports Server - Developer Edition, TIBCO JasperReports Server for AWS Marketplace, TIBCO JasperReports Server for ActiveMatrix BPM, and TIBCO JasperReports Server for Microsoft Azure contains difficult to exploit Reflected Cross Site Scripting (XSS) vulnerabilities that allow a low privileged attacker with network access to execute scripts targeting the affected system or the victim's local system. Affected releases are TIBCO Software Inc.'s TIBCO JasperReports Server: versions 8.0.1 and below, TIBCO JasperReports Server - Community Edition: versions 8.0.1 and below, TIBCO JasperReports Server - Developer Edition: versions 8.0.0 and below, TIBCO JasperReports Server for AWS Marketplace: versions 8.0.1 and below, TIBCO JasperReports Server for ActiveMatrix BPM: versions 7.9.2 and below, and TIBCO JasperReports Server for Microsoft Azure: versions 8.0.1 and below.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-22773?

1 open source package ship an affected version, including jasperreports. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jasperreports` | Bitnami | All versions | 8.0.2 |

Products: Tibco Jasperreports Server.

## How do I fix CVE-2022-22773?

Upgrade jasperreports to 8.0.2 or later.

## Is CVE-2022-22773 being exploited?

There is no known exploitation of CVE-2022-22773 in the wild and no public exploit code.

## Other vulnerabilities in TIBCO JasperReports Server

- [CVE-2018-5430](https://insights.sbomify.com/CVE-2018-5430/): TIBCO JasperReports Server Information Disclosure (high 7.7, exploited in the wild)
- [CVE-2018-18815](https://insights.sbomify.com/CVE-2018-18815/): TIBCO JasperReports Server User Information Disclosure (critical 10.0)
- [CVE-2017-5533](https://insights.sbomify.com/CVE-2017-5533/): TIBCO JasperReports Server credentials disclosure (critical 9.3)
- [CVE-2022-41561](https://insights.sbomify.com/CVE-2022-41561/): TIBCO JasperReports Server RCE Vulnerability (critical 9.1)
- [CVE-2022-41563](https://insights.sbomify.com/CVE-2022-41563/): TIBCO JasperReports Server Stored XSS Vulnerability (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22773 and fix it if it is affected.

What it is: CVE-2022-22773 is a high-severity cross-site scripting vulnerability in TIBCO JasperReports Server, published on 17 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-22773 in the wild and no public exploit code.

Affected packages and fixed versions:
- jasperreports (Bitnami): affected all versions; fixed in 8.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22773/ (Markdown: https://insights.sbomify.com/CVE-2022-22773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22773
- OSV: https://osv.dev/vulnerability/CVE-2022-22773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22773/
Summaries are generated and may contain mistakes; the official description above is the record.
