# CVE-2022-22817: Arbitrary expression injection in Pillow

> Attackers can execute arbitrary code via unsafe expression evaluation in the Pillow image processing library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2022
- **Updated:** 15 Oct 2024
- **Also known as:** ALPINE-CVE-2022-22817, BIT-pillow-2022-22817, DEBIAN-CVE-2022-22817, GHSA-8vj2-vxx3-667w, PYSEC-2022-10, ROOT-APP-PYPI-CVE-2022-22817, UBUNTU-CVE-2022-22817, USN-5227-3

## What is CVE-2022-22817?

CVE-2022-22817 is a critical code injection vulnerability in Debian Debian Linux, published on 7 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PIL.ImageMath.eval in Pillow before 9.0.0 allows evaluation of arbitrary expressions, such as ones that use the Python exec method. A lambda expression could also be used.

## Which versions are affected by CVE-2022-22817?

4 open source packages ship an affected version, including pillow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 9.0.1 |
| `pillow` | PyPI | All versions | 9.0.0 |
| `pillow` | PyPI | All versions | 9.0.1 |
| `pillow` | PyPI | All versions | 9.0.1 |

Products: Debian Debian Linux, Python Pillow.

## How do I fix CVE-2022-22817?

Upgrade pillow to a fixed version for your release line: 9.0.1 or 9.0.0.

## Is CVE-2022-22817 being exploited?

There is no known exploitation of CVE-2022-22817 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22817 and fix it if it is affected.

What it is: CVE-2022-22817 is a critical code injection vulnerability in Debian Debian Linux, published on 7 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22817 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 9.0.1
- pillow (PyPI): affected all versions; fixed in 9.0.0
- pillow (PyPI): affected all versions; fixed in 9.0.1
- pillow (PyPI): affected all versions; fixed in 9.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22817/ (Markdown: https://insights.sbomify.com/CVE-2022-22817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22817
- OSV: https://osv.dev/vulnerability/CVE-2022-22817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22817/
Summaries are generated and may contain mistakes; the official description above is the record.
