CVE-2022-22818 Cross-site Scripting in Django
Cross-site scripting vulnerability in Django's debug template tag allows attackers to execute arbitrary scripts if debug mode is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-22818?
CVE-2022-22818 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 3 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The {% debug %} template tag in Django 2.2 before 2.2.27, 3.2 before 3.2.12, and 4.0 before 4.0.2 does not properly encode the current context. This may lead to XSS.
Weakness: CWE-79
Which versions are affected by CVE-2022-22818?
8 open source packages ship an affected version, including django and Django. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 2.2.0 | 2.2.27, 3.2.12, 4.0.2 |
django PyPI | From 2.2 | 2.2.27, 3.2.12, 4.0.2 |
django PyPI | From 2.2 | 2.2.27 |
django PyPI | From 3.2 | 3.2.12 |
django PyPI | From 4.0 | 4.0.2 |
Django PyPI | From 2.2 | 2.2.27 |
2 more packages
Django PyPI | From 3.2 | 3.2.12 |
Django PyPI | From 4.0 | 4.0.2 |
Products include Debian Debian Linux, Djangoproject Django, Fedoraproject Fedora.
How do I fix CVE-2022-22818?
Upgrade django to a fixed version for your release line: 2.2.27, 3.2.12 or 4.0.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-22818 being exploited?
There is no known exploitation of CVE-2022-22818 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-django-2022-22818, CLSA-2025-1760659889, DEBIAN-CVE-2022-22818, GHSA-95rw-fx8r-36v6, PYSEC-2022-19, UBUNTU-CVE-2022-22818.