# CVE-2022-22818: Cross-site Scripting in Django

> Cross-site scripting vulnerability in Django's debug template tag allows attackers to execute arbitrary scripts if debug mode is enabled.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-django-2022-22818, CLSA-2025-1760659889, DEBIAN-CVE-2022-22818, GHSA-95rw-fx8r-36v6, PYSEC-2022-19, UBUNTU-CVE-2022-22818

## What is CVE-2022-22818?

CVE-2022-22818 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 3 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The {% debug %} template tag in Django 2.2 before 2.2.27, 3.2 before 3.2.12, and 4.0 before 4.0.2 does not properly encode the current context. This may lead to XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-22818?

8 open source packages ship an affected version, including django and Django. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 2.2.0 | 2.2.27, 3.2.12, 4.0.2 |
| `django` | PyPI | From 2.2 | 2.2.27, 3.2.12, 4.0.2 |
| `django` | PyPI | From 2.2 | 2.2.27 |
| `django` | PyPI | From 3.2 | 3.2.12 |
| `django` | PyPI | From 4.0 | 4.0.2 |
| `Django` | PyPI | From 2.2 | 2.2.27 |
| `Django` | PyPI | From 3.2 | 3.2.12 |
| `Django` | PyPI | From 4.0 | 4.0.2 |

Products: Debian Debian Linux, Djangoproject Django, Fedoraproject Fedora.

## How do I fix CVE-2022-22818?

Upgrade django to a fixed version for your release line: 2.2.27, 3.2.12 or 4.0.2.

## Is CVE-2022-22818 being exploited?

There is no known exploitation of CVE-2022-22818 in the wild and no public exploit code.

Public exploit code:

- This repo reproduce xss attack on django 4.0.1 (see CVE-2022-22818) (github_poc): https://github.com/Prikalel/django-xss-example

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22818 and fix it if it is affected.

What it is: CVE-2022-22818 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 3 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-22818 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 2.2.0; fixed in 2.2.27, 3.2.12, 4.0.2
- django (PyPI): affected from 2.2; fixed in 2.2.27, 3.2.12, 4.0.2
- django (PyPI): affected from 2.2; fixed in 2.2.27
- django (PyPI): affected from 3.2; fixed in 3.2.12
- django (PyPI): affected from 4.0; fixed in 4.0.2
- Django (PyPI): affected from 2.2; fixed in 2.2.27
- Django (PyPI): affected from 3.2; fixed in 3.2.12
- Django (PyPI): affected from 4.0; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22818/ (Markdown: https://insights.sbomify.com/CVE-2022-22818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22818
- OSV: https://osv.dev/vulnerability/CVE-2022-22818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22818/
Summaries are generated and may contain mistakes; the official description above is the record.
