# CVE-2022-22821: Path Traversal in nemo-toolkit

> An attacker with admin privileges can delete any directory via path traversal in the NVIDIA NeMo ASR WebApp.

- **Severity:** Low 2.0 (`CVSS:3.1/AC:L/AV:L/A:N/C:N/I:L/PR:H/S:U/UI:R`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-9hg3-hmmf-c3gr, GHSA-rpx7-33j2-xx9x, PYSEC-2026-685

## What is CVE-2022-22821?

CVE-2022-22821 is a low-severity path traversal vulnerability in n/a, published on 8 Jan 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

NVIDIA NeMo before 1.6.0 contains a vulnerability in ASR WebApp, in which ../ Path Traversal may lead to deletion of any directory when admin privileges are available.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-22821?

5 open source packages ship an affected version, including nemo-toolkit and nemo_toolkit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nemo-toolkit` | PyPI | All versions | 1.6.0 |
| `nemo-toolkit` | PyPI | All versions | 1.6.0 |
| `nemo-toolkit` | PyPI | All versions | 1.6.0 |
| `nemo-toolkit` | PyPI | All versions | 1.6.0 |
| `nemo_toolkit` | PyPI | All versions | 1.6.0 |

Products: Nvidia Nemo.

## How do I fix CVE-2022-22821?

Upgrade nemo-toolkit to 1.6.0 or later.

## Is CVE-2022-22821 being exploited?

There is no known exploitation of CVE-2022-22821 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-0081](https://insights.sbomify.com/CVE-2024-0081/): Denial of service in NeMo (high 8.6)
- [CVE-2025-33245](https://insights.sbomify.com/CVE-2025-33245/): NVIDIA NeMo Framework contains a vulnerability where malicious data could cause remote code execution (high 8.0)
- [CVE-2026-24252](https://insights.sbomify.com/CVE-2026-24252/): Command injection in NeMo Framework (high 7.8)
- [CVE-2026-24155](https://insights.sbomify.com/CVE-2026-24155/): Code injection in NeMo Framework (high 7.8)
- [CVE-2026-24228](https://insights.sbomify.com/CVE-2026-24228/): Deserialization in NeMo Framework (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22821 and fix it if it is affected.

What it is: CVE-2022-22821 is a low-severity path traversal vulnerability in n/a, published on 8 Jan 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-22821 in the wild and no public exploit code.

Affected packages and fixed versions:
- nemo-toolkit (PyPI): affected all versions; fixed in 1.6.0
- nemo-toolkit (PyPI): affected all versions; fixed in 1.6.0
- nemo-toolkit (PyPI): affected all versions; fixed in 1.6.0
- nemo-toolkit (PyPI): affected all versions; fixed in 1.6.0
- nemo_toolkit (PyPI): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22821/ (Markdown: https://insights.sbomify.com/CVE-2022-22821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22821
- OSV: https://osv.dev/vulnerability/CVE-2022-22821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22821/
Summaries are generated and may contain mistakes; the official description above is the record.
