# CVE-2022-22846: dnslib has DNS reply verification issue

> The dnslib Python library fails to validate DNS transaction IDs, allowing attackers to spoof DNS responses and bypass security controls.

- **Severity:** High 7.5 (`CVSS:3.1/AC:L/AV:N/A:N/C:N/I:H/PR:N/S:U/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-22846, GHSA-r478-c2pc-m7gx, PYSEC-2022-4, UBUNTU-CVE-2022-22846

## What is CVE-2022-22846?

CVE-2022-22846 is a high-severity vulnerability in n/a, published on 9 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The dnslib package through 0.9.16 for Python does not verify that the ID value in a DNS reply matches an ID value in a query.

## Which versions are affected by CVE-2022-22846?

3 open source packages ship an affected version, including dnslib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dnslib` | PyPI | All versions | 0.9.17 |
| `dnslib` | PyPI | All versions | 0.9.17 |
| `dnslib` | PyPI | All versions | 0.9.17 |

Products: Dnslib Project Dnslib.

## How do I fix CVE-2022-22846?

Upgrade dnslib to 0.9.17 or later.

## Is CVE-2022-22846 being exploited?

There is no known exploitation of CVE-2022-22846 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22846 and fix it if it is affected.

What it is: CVE-2022-22846 is a high-severity vulnerability in n/a, published on 9 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22846 in the wild and no public exploit code.

Affected packages and fixed versions:
- dnslib (PyPI): affected all versions; fixed in 0.9.17
- dnslib (PyPI): affected all versions; fixed in 0.9.17
- dnslib (PyPI): affected all versions; fixed in 0.9.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22846/ (Markdown: https://insights.sbomify.com/CVE-2022-22846/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22846
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22846
- OSV: https://osv.dev/vulnerability/CVE-2022-22846

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22846/
Summaries are generated and may contain mistakes; the official description above is the record.
