CVE-2022-22912 Prototype pollution in Plist before 3.0.5 can cause denial of service
Critical 9.8
Published
Updated
Check this codebase for CVE-2022-22912 and fix it if it is affected.
What it is: CVE-2022-22912 is a critical vulnerability in n/a, published on 17 Feb 2022.
Exploitation: There is no known exploitation of CVE-2022-22912 in the wild and no public exploit code.
Affected packages and fixed versions:
- plist (npm): affected all versions; fixed in 3.0.5
- plist (npm): affected all versions; fixed in 3.0.5
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2022-22912/ (Markdown: https://insights.sbomify.com/CVE-2022-22912/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2022-22912?
CVE-2022-22912 is a critical vulnerability in n/a, published on 17 Feb 2022.
Official description
Prototype pollution vulnerability via .parse() in Plist before v3.0.4 allows attackers to cause a Denial of Service (DoS) and may lead to remote code execution.
Weakness: CWE-1321
Which versions are affected by CVE-2022-22912?
2 open source packages ship an affected version, including plist. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plist npm | All versions | 3.0.5 |
plist npm | All versions | 3.0.5 |
Products include Plist Project Plist.
How do I fix CVE-2022-22912?
Upgrade plist to 3.0.5 or later.
Is CVE-2022-22912 being exploited?
There is no known exploitation of CVE-2022-22912 in the wild and no public exploit code.
Sources
Also known as GHSA-4cpg-3vgw-4877.