{"answers":{"affected":"2 open source packages ship an affected version, including plist. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-22912 in the wild and no public exploit code.","fix":"Upgrade plist to 3.0.5 or later.","what":"CVE-2022-22912 is a critical vulnerability in n/a, published on 17 Feb 2022."},"fix_prompt":"Check this codebase for CVE-2022-22912 and fix it if it is affected.\n\nWhat it is: CVE-2022-22912 is a critical vulnerability in n/a, published on 17 Feb 2022. \nExploitation: There is no known exploitation of CVE-2022-22912 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- plist (npm): affected all versions; fixed in 3.0.5\n- plist (npm): affected all versions; fixed in 3.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-22912/ (Markdown: https://insights.sbomify.com/CVE-2022-22912/index.md)","id":"CVE-2022-22912","markdown":"https://insights.sbomify.com/CVE-2022-22912/index.md","name":"CVE-2022-22912","record":{"aliases":["GHSA-4cpg-3vgw-4877"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"plist","vendor":"plist_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"Prototype pollution vulnerability via .parse() in Plist before v3.0.4 allows attackers to cause a Denial of Service (DoS) and may lead to remote code execution.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Prototype pollution in Plist before 3.0.5 can cause denial of service","id":"CVE-2022-22912","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Path traversal in n/a","id":"CVE-2022-22914"},"packages":[{"ecosystem":"npm","fixed":["3.0.5"],"introduced":["0"],"last_affected":[],"package":"plist","purl":null,"source":"GHSA-4cpg-3vgw-4877"},{"ecosystem":"npm","fixed":["3.0.5"],"introduced":["0"],"last_affected":[],"package":"plist","purl":"pkg:npm/plist","source":"GHSA-4cpg-3vgw-4877"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2022-22909"},"products":["n/a"],"published":"2022-02-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-22912/"}