# CVE-2022-22912: Prototype pollution in Plist before 3.0.5 can cause denial of service


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 17 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-4cpg-3vgw-4877

## What is CVE-2022-22912?

CVE-2022-22912 is a critical vulnerability in n/a, published on 17 Feb 2022. 

### Official description

Prototype pollution vulnerability via .parse() in Plist before v3.0.4 allows attackers to cause a Denial of Service (DoS) and may lead to remote code execution.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-22912?

2 open source packages ship an affected version, including plist. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plist` | npm | All versions | 3.0.5 |
| `plist` | npm | All versions | 3.0.5 |

Products: Plist Project Plist.

## How do I fix CVE-2022-22912?

Upgrade plist to 3.0.5 or later.

## Is CVE-2022-22912 being exploited?

There is no known exploitation of CVE-2022-22912 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22912 and fix it if it is affected.

What it is: CVE-2022-22912 is a critical vulnerability in n/a, published on 17 Feb 2022. 
Exploitation: There is no known exploitation of CVE-2022-22912 in the wild and no public exploit code.

Affected packages and fixed versions:
- plist (npm): affected all versions; fixed in 3.0.5
- plist (npm): affected all versions; fixed in 3.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22912/ (Markdown: https://insights.sbomify.com/CVE-2022-22912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22912
- OSV: https://osv.dev/vulnerability/CVE-2022-22912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22912/
Summaries are generated and may contain mistakes; the official description above is the record.
