# CVE-2022-22931: Path traversal in Apache James 3.6.1

> A path traversal flaw in Apache James allows authenticated users to access other users' data stores by bypassing directory validation checks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-v84g-cf5j-xjqx

## What is CVE-2022-22931?

CVE-2022-22931 is a medium-severity path traversal vulnerability in Apache James, published on 7 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Fix of CVE-2021-40525 do not prepend delimiters upon valid directory validations. Affected implementations include: - maildir mailbox store - Sieve file repository This enables a user to access other users data stores (limited to user names being prefixed by the value of the username being used).

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-22931?

2 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.james:james-server` | Maven | All versions | 3.6.2 |
| `org.apache.james:james-server` | Maven | All versions | 3.6.2 |

Products: Apache James.

## How do I fix CVE-2022-22931?

Upgrade org.apache.james:james-server to 3.6.2 or later.

## Is CVE-2022-22931 being exploited?

There is no known exploitation of CVE-2022-22931 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/asf__james-project_CVE-2022-22931_3-6-0 (github_poc): https://github.com/shoucheng3/asf__james-project_CVE-2022-22931_3-6-0

## Other vulnerabilities in Apache James

- [CVE-2023-51518](https://insights.sbomify.com/CVE-2023-51518/): Apache James server: Privilege escalation via JMX pre-authentication deserialisation (critical 9.8)
- [CVE-2019-0228](https://insights.sbomify.com/CVE-2019-0228/): Vulnerability that affects org.apache.pdfbox:pdfbox (critical 9.8)
- [CVE-2021-40525](https://insights.sbomify.com/CVE-2021-40525/): Sieve file storage vulnerable to path traversal attacks (critical 9.1)
- [CVE-2023-26269](https://insights.sbomify.com/CVE-2023-26269/): Apache James server: Privilege escalation through unauthenticated JMX (high 7.8)
- [CVE-2006-2806](https://insights.sbomify.com/CVE-2006-2806/): Denial of service in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22931 and fix it if it is affected.

What it is: CVE-2022-22931 is a medium-severity path traversal vulnerability in Apache James, published on 7 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22931 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.james:james-server (Maven): affected all versions; fixed in 3.6.2
- org.apache.james:james-server (Maven): affected all versions; fixed in 3.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22931/ (Markdown: https://insights.sbomify.com/CVE-2022-22931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22931
- OSV: https://osv.dev/vulnerability/CVE-2022-22931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22931/
Summaries are generated and may contain mistakes; the official description above is the record.
