# CVE-2022-22932: Path traversal flaws

> Path traversal in Apache Karaf obr commands and maven plugin allows breaking out of expected folders, requiring an upgrade to mitigate.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-544x-2jx9-4pfg

## What is CVE-2022-22932?

CVE-2022-22932 is a medium-severity path traversal vulnerability in Apache Karaf, published on 26 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Karaf obr:* commands and run goal on the karaf-maven-plugin have partial path traversal which allows to break out of expected folder. The risk is low as obr:* commands are not very used and the entry is set by user. This has been fixed in revision: https://gitbox.apache.org/repos/asf?p=karaf.git;h=36a2bc4 https://gitbox.apache.org/repos/asf?p=karaf.git;h=52b70cf Mitigation: Apache Karaf users should upgrade to 4.2.15 or 4.3.6 or later as soon as possible, or use correct path. JIRA Tickets: https://issues.apache.org/jira/browse/KARAF-7326

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-22932?

4 open source packages ship an affected version, including org.apache.karaf:apache-karaf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.karaf:apache-karaf` | Maven | All versions | 4.2.15 |
| `org.apache.karaf:apache-karaf` | Maven | All versions | 4.2.15 |
| `org.apache.karaf:apache-karaf` | Maven | From 4.3.0 | 4.3.6 |
| `org.apache.karaf:apache-karaf` | Maven | From 4.3.0 | 4.3.6 |

Products: Apache Karaf.

## How do I fix CVE-2022-22932?

Upgrade org.apache.karaf:apache-karaf to a fixed version for your release line: 4.2.15 or 4.3.6.

## Is CVE-2022-22932 being exploited?

There is no known exploitation of CVE-2022-22932 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/asf__karaf_CVE-2022-22932_4-3-5 (github_poc): https://github.com/shoucheng3/asf__karaf_CVE-2022-22932_4-3-5

## Other vulnerabilities in Apache Karaf

- [CVE-2026-91012](https://insights.sbomify.com/CVE-2026-91012/): Apache Karaf: Path Traversal in Config Service Allows Manager-to-Admin Privilege Escalation (critical 9.8)
- [CVE-2026-91048](https://insights.sbomify.com/CVE-2026-91048/): Missing authorization in Apache Karaf (critical 9.8)
- [CVE-2022-40145](https://insights.sbomify.com/CVE-2022-40145/): Apache Karaf: JDBC JAAS LDAP injection (critical 9.8)
- [CVE-2018-11788](https://insights.sbomify.com/CVE-2018-11788/): XML External Entity Reference in Apache Karaf (critical 9.8)
- [CVE-2026-92142](https://insights.sbomify.com/CVE-2026-92142/): Apache Karaf: Authorization bypass in JMX MBean lifecycle operations (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22932 and fix it if it is affected.

What it is: CVE-2022-22932 is a medium-severity path traversal vulnerability in Apache Karaf, published on 26 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22932 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.karaf:apache-karaf (Maven): affected all versions; fixed in 4.2.15
- org.apache.karaf:apache-karaf (Maven): affected all versions; fixed in 4.2.15
- org.apache.karaf:apache-karaf (Maven): affected from 4.3.0; fixed in 4.3.6
- org.apache.karaf:apache-karaf (Maven): affected from 4.3.0; fixed in 4.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22932/ (Markdown: https://insights.sbomify.com/CVE-2022-22932/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22932
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22932
- OSV: https://osv.dev/vulnerability/CVE-2022-22932

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22932/
Summaries are generated and may contain mistakes; the official description above is the record.
