# CVE-2022-22941: SaltStack Salt Permissions Bypass

> Authenticated users can bypass publisher_acl restrictions to execute commands on any minion connected to a syndic master.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2022
- **Updated:** 5 May 2025
- **Also known as:** GHSA-qcr3-hr2f-6557, PYSEC-2022-174, UBUNTU-CVE-2022-22941

## What is CVE-2022-22941?

CVE-2022-22941 is a high-severity missing authorization vulnerability in Saltstack Salt, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in SaltStack Salt in versions before 3002.8, 3003.4, 3004.1. When configured as a Master-of-Masters, with a publisher_acl, if a user configured in the publisher_acl targets any minion connected to the Syndic, the Salt Master incorrectly interpreted no valid targets as valid, allowing configured users to target any of the minions connected to the syndic with their configured commands. This requires a syndic master combined with publisher_acl configured on the Master-of-Masters, allowing users specified in the publisher_acl to bypass permissions, publishing authorized commands to any configured minion.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2022-22941?

7 open source packages ship an affected version, including salt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `salt` | PyPI | All versions | 3002.8 |
| `salt` | PyPI | All versions | 3002.8 |
| `salt` | PyPI | All versions | 3002.8 |
| `salt` | PyPI | From 3003 | 3003.4 |
| `salt` | PyPI | From 3003 | 3003.4 |
| `salt` | PyPI | From 3004 | 3004.1 |
| `salt` | PyPI | From 3004 | 3004.1 |

Products: Saltstack Salt.

## How do I fix CVE-2022-22941?

Upgrade salt to a fixed version for your release line: 3002.8, 3003.4 or 3004.1.

## Is CVE-2022-22941 being exploited?

There is no known exploitation of CVE-2022-22941 in the wild and no public exploit code.

## Other vulnerabilities in Saltstack Salt

- [CVE-2013-4437](https://insights.sbomify.com/CVE-2013-4437/): SaltStack insecurely uses /tmp (critical 10.0)
- [CVE-2013-6617](https://insights.sbomify.com/CVE-2013-6617/): SaltStack Privilege Escalation vulnerability (critical 10.0)
- [CVE-2021-33226](https://insights.sbomify.com/CVE-2021-33226/): Code injection in n/a (critical 9.8)
- [CVE-2021-25315](https://insights.sbomify.com/CVE-2021-25315/): salt-api unauthenticated remote code execution (critical 9.8)
- [CVE-2018-15751](https://insights.sbomify.com/CVE-2018-15751/): SaltStack Salt Remote command execution and incorrect access control when using salt-api (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22941 and fix it if it is affected.

What it is: CVE-2022-22941 is a high-severity missing authorization vulnerability in Saltstack Salt, published on 29 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22941 in the wild and no public exploit code.

Affected packages and fixed versions:
- salt (PyPI): affected all versions; fixed in 3002.8
- salt (PyPI): affected all versions; fixed in 3002.8
- salt (PyPI): affected all versions; fixed in 3002.8
- salt (PyPI): affected from 3003; fixed in 3003.4
- salt (PyPI): affected from 3003; fixed in 3003.4
- salt (PyPI): affected from 3004; fixed in 3004.1
- salt (PyPI): affected from 3004; fixed in 3004.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22941/ (Markdown: https://insights.sbomify.com/CVE-2022-22941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22941
- OSV: https://osv.dev/vulnerability/CVE-2022-22941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22941/
Summaries are generated and may contain mistakes; the official description above is the record.
