# CVE-2022-22968: Improper handling of case sensitivity in Spring Framework

> Attackers can bypass field protection in Spring Framework DataBinder due to case-sensitive pattern matching, allowing unauthorized modification of protected fields.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2022
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2022-22968, GHSA-g5mm-vmx4-3rg7, ROOT-APP-MAVEN-CVE-2022-22968, UBUNTU-CVE-2022-22968

## What is CVE-2022-22968?

CVE-2022-22968 is a medium-severity missing authorization vulnerability in Netapp Active Iq Unified Manager, published on 14 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Spring Framework versions 5.3.0 - 5.3.18, 5.2.0 - 5.2.20, and older unsupported versions, the patterns for disallowedFields on a DataBinder are case sensitive which means a field is not effectively protected unless it is listed with both upper and lower case for the first character of the field, including upper and lower case for the first character of all nested fields within the property path.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2022-22968?

4 open source packages ship an affected version, including org.springframework:spring-context. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-context` | Maven | All versions | 5.2.21.RELEASE |
| `org.springframework:spring-context` | Maven | All versions | 5.2.21.RELEASE |
| `org.springframework:spring-context` | Maven | From 5.3.0 | 5.3.19 |
| `org.springframework:spring-context` | Maven | From 5.3.0 | 5.3.19 |

Products: Netapp Active Iq Unified Manager, Netapp Cloud Secure Agent, Netapp Metrocluster Tiebreaker, Netapp Snap Creator Framework, Netapp Snapmanager, Oracle Mysql Enterprise Monitor, Vmware Spring Framework.

## How do I fix CVE-2022-22968?

Upgrade org.springframework:spring-context to a fixed version for your release line: 5.2.21.RELEASE or 5.3.19.

## Is CVE-2022-22968 being exploited?

There is no known exploitation of CVE-2022-22968 in the wild and no public exploit code.

Public exploit code:

- Testing CVE-2022-22968 (github_poc): https://github.com/MarcinGadz/spring-rce-poc

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22968 and fix it if it is affected.

What it is: CVE-2022-22968 is a medium-severity missing authorization vulnerability in Netapp Active Iq Unified Manager, published on 14 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22968 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-context (Maven): affected all versions; fixed in 5.2.21.RELEASE
- org.springframework:spring-context (Maven): affected all versions; fixed in 5.2.21.RELEASE
- org.springframework:spring-context (Maven): affected from 5.3.0; fixed in 5.3.19
- org.springframework:spring-context (Maven): affected from 5.3.0; fixed in 5.3.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22968/ (Markdown: https://insights.sbomify.com/CVE-2022-22968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22968
- OSV: https://osv.dev/vulnerability/CVE-2022-22968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22968/
Summaries are generated and may contain mistakes; the official description above is the record.
