CVE-2022-22969 Denial of service in Spring Security OAuth2
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2022-22969?
CVE-2022-22969 is a medium-severity vulnerability in Spring Security OAuth, published on 21 Apr 2022.
Official description
<Issue Description> Spring Security OAuth versions 2.5.x prior to 2.5.2 and older unsupported versions are susceptible to a Denial-of-Service (DoS) attack via the initiation of the Authorization Request in an OAuth 2.0 Client application. A malicious user or attacker can send multiple requests initiating the Authorization Request for the Authorization Code Grant, which has the potential of exhausting system resources using a single session. This vulnerability exposes OAuth 2.0 Client applications only.
Which versions are affected by CVE-2022-22969?
4 open source packages ship an affected version, including org.springframework.security.oauth:spring-security-oauth2. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.4.0.RELEASE | 2.4.2.RELEASE |
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.4.0.RELEASE | 2.4.2.RELEASE |
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.5.0.RELEASE | 2.5.2.RELEASE |
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.5.0.RELEASE | 2.5.2.RELEASE |
Products include Oracle Communications Design Studio, Pivotal Spring Security Oauth.
How do I fix CVE-2022-22969?
Upgrade org.springframework.security.oauth:spring-security-oauth2 to a fixed version for your release line: 2.4.2.RELEASE or 2.5.2.RELEASE.
Is CVE-2022-22969 being exploited?
There is no known exploitation of CVE-2022-22969 in the wild and no public exploit code.
Sources
Also known as GHSA-c2cp-3xj9-97w9.