# CVE-2022-22970: Denial of service in Spring Framework

> Attackers can cause denial of service in Spring Framework applications handling file uploads via data binding to MultipartFile fields.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2022
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2022-22970, GHSA-hh26-6xwr-ggv7, RHLW-2026-a5ec8923604c1851, ROOT-APP-MAVEN-CVE-2022-22970, UBUNTU-CVE-2022-22970

## What is CVE-2022-22970?

CVE-2022-22970 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 12 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In spring framework versions prior to 5.3.20+ , 5.2.22+ and old unsupported versions, applications that handle file uploads are vulnerable to DoS attack if they rely on data binding to set a MultipartFile or javax.servlet.Part to a field in a model object.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2022-22970?

4 open source packages ship an affected version, including org.springframework:spring-beans. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-beans` | Maven | All versions | 5.2.22.RELEASE |
| `org.springframework:spring-beans` | Maven | All versions | 5.2.22.RELEASE |
| `org.springframework:spring-beans` | Maven | From 5.3.0 | 5.3.20 |
| `org.springframework:spring-beans` | Maven | From 5.3.0 | 5.3.20 |

Products: Netapp Active Iq Unified Manager, Netapp Brocade San Navigator, Netapp Cloud Secure Agent, Netapp Oncommand Insight, Oracle Financial Services Crime and Compliance Management Studio, Vmware Spring Framework.

## How do I fix CVE-2022-22970?

Upgrade org.springframework:spring-beans to a fixed version for your release line: 5.2.22.RELEASE or 5.3.20.

## Is CVE-2022-22970 being exploited?

There is no known exploitation of CVE-2022-22970 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Performant-Labs/CVE-2022-22970 (github_poc): https://github.com/Performant-Labs/CVE-2022-22970

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22970 and fix it if it is affected.

What it is: CVE-2022-22970 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 12 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22970 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-beans (Maven): affected all versions; fixed in 5.2.22.RELEASE
- org.springframework:spring-beans (Maven): affected all versions; fixed in 5.2.22.RELEASE
- org.springframework:spring-beans (Maven): affected from 5.3.0; fixed in 5.3.20
- org.springframework:spring-beans (Maven): affected from 5.3.0; fixed in 5.3.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22970/ (Markdown: https://insights.sbomify.com/CVE-2022-22970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22970
- OSV: https://osv.dev/vulnerability/CVE-2022-22970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22970/
Summaries are generated and may contain mistakes; the official description above is the record.
