CVE-2022-22971 Allocation of Resources Without Limits or Throttling in Spring Framework
An authenticated user can cause a denial of service in applications using STOMP over WebSocket endpoints in the Spring Framework.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-22971?
CVE-2022-22971 is a medium-severity denial of service vulnerability in Netapp Cloud Secure Agent, published on 12 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In spring framework versions prior to 5.3.20+ , 5.2.22+ and old unsupported versions, application with a STOMP over WebSocket endpoint is vulnerable to a denial of service attack by an authenticated user.
Weakness: CWE-770
Which versions are affected by CVE-2022-22971?
4 open source packages ship an affected version, including org.springframework:spring-messaging. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework:spring-messaging Maven | All versions | 5.2.22.RELEASE |
org.springframework:spring-messaging Maven | All versions | 5.2.22.RELEASE |
org.springframework:spring-messaging Maven | From 5.3.0 | 5.3.20 |
org.springframework:spring-messaging Maven | From 5.3.0 | 5.3.20 |
Products include Netapp Cloud Secure Agent, Netapp Oncommand Insight, Oracle Financial Services Crime and Compliance Management Studio, Vmware Spring Framework.
How do I fix CVE-2022-22971?
Upgrade org.springframework:spring-messaging to a fixed version for your release line: 5.2.22.RELEASE or 5.3.20.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-22971 being exploited?
There is no known exploitation of CVE-2022-22971 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Netapp Cloud Secure Agent
Sources
Also known as DEBIAN-CVE-2022-22971, GHSA-rqph-vqwm-22vc, RHLW-2026-8279a9b7f6bb0be6, UBUNTU-CVE-2022-22971.