# CVE-2022-22971: Allocation of Resources Without Limits or Throttling in Spring Framework

> An authenticated user can cause a denial of service in applications using STOMP over WebSocket endpoints in the Spring Framework.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2022
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2022-22971, GHSA-rqph-vqwm-22vc, RHLW-2026-8279a9b7f6bb0be6, UBUNTU-CVE-2022-22971

## What is CVE-2022-22971?

CVE-2022-22971 is a medium-severity denial of service vulnerability in Netapp Cloud Secure Agent, published on 12 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In spring framework versions prior to 5.3.20+ , 5.2.22+ and old unsupported versions, application with a STOMP over WebSocket endpoint is vulnerable to a denial of service attack by an authenticated user.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2022-22971?

4 open source packages ship an affected version, including org.springframework:spring-messaging. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-messaging` | Maven | All versions | 5.2.22.RELEASE |
| `org.springframework:spring-messaging` | Maven | All versions | 5.2.22.RELEASE |
| `org.springframework:spring-messaging` | Maven | From 5.3.0 | 5.3.20 |
| `org.springframework:spring-messaging` | Maven | From 5.3.0 | 5.3.20 |

Products: Netapp Cloud Secure Agent, Netapp Oncommand Insight, Oracle Financial Services Crime and Compliance Management Studio, Vmware Spring Framework.

## How do I fix CVE-2022-22971?

Upgrade org.springframework:spring-messaging to a fixed version for your release line: 5.2.22.RELEASE or 5.3.20.

## Is CVE-2022-22971 being exploited?

There is no known exploitation of CVE-2022-22971 in the wild and no public exploit code.

Public exploit code:

- https://github.com/tchize/CVE-2022-22971 (github_poc): https://github.com/tchize/CVE-2022-22971

## Other vulnerabilities in Netapp Cloud Secure Agent

- [CVE-2021-3859](https://insights.sbomify.com/CVE-2021-3859/): Undertow vulnerable to Denial of Service (DoS) attacks (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22971 and fix it if it is affected.

What it is: CVE-2022-22971 is a medium-severity denial of service vulnerability in Netapp Cloud Secure Agent, published on 12 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22971 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-messaging (Maven): affected all versions; fixed in 5.2.22.RELEASE
- org.springframework:spring-messaging (Maven): affected all versions; fixed in 5.2.22.RELEASE
- org.springframework:spring-messaging (Maven): affected from 5.3.0; fixed in 5.3.20
- org.springframework:spring-messaging (Maven): affected from 5.3.0; fixed in 5.3.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22971/ (Markdown: https://insights.sbomify.com/CVE-2022-22971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22971
- OSV: https://osv.dev/vulnerability/CVE-2022-22971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22971/
Summaries are generated and may contain mistakes; the official description above is the record.
