# CVE-2022-22975: An issue was discovered in the Pinniped Supervisor with either LADPIdentityProvider or ActiveDirectoryIdentityProvider resources.


- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 11 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-pinniped-2022-22975, GHSA-hvrf-5hhv-4348

## What is CVE-2022-22975?

CVE-2022-22975 is a medium-severity vulnerability in Pinniped, published on 11 May 2022. 

### Official description

An issue was discovered in the Pinniped Supervisor with either LADPIdentityProvider or ActiveDirectoryIdentityProvider resources. An attack would involve the malicious user changing the common name (CN) of their user entry on the LDAP or AD server to include special characters, which could be used to perform LDAP query injection on the Supervisor's LDAP query which determines their Kubernetes group membership.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-22975?

1 open source package ship an affected version, including pinniped. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pinniped` | Bitnami | From 0.9.0 | 0.17.0 |

Products: Vmware Pinniped.

## How do I fix CVE-2022-22975?

Upgrade pinniped to 0.17.0 or later.

## Is CVE-2022-22975 being exploited?

There is no known exploitation of CVE-2022-22975 in the wild and no public exploit code.

## Other vulnerabilities in Pinniped

- [CVE-2022-31677](https://insights.sbomify.com/CVE-2022-31677/): Pinniped Supervisor Insufficient Session Expiration vulnerability (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22975 and fix it if it is affected.

What it is: CVE-2022-22975 is a medium-severity vulnerability in Pinniped, published on 11 May 2022. 
Exploitation: There is no known exploitation of CVE-2022-22975 in the wild and no public exploit code.

Affected packages and fixed versions:
- pinniped (Bitnami): affected from 0.9.0; fixed in 0.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22975/ (Markdown: https://insights.sbomify.com/CVE-2022-22975/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22975
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22975
- OSV: https://osv.dev/vulnerability/CVE-2022-22975

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22975/
Summaries are generated and may contain mistakes; the official description above is the record.
