# CVE-2022-22976: Integer overflow in BCrypt class in Spring Security

> An integer overflow in Spring Security's BCrypt encoder with maximum work factor skips salt rounds, weakening password hashing security.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-wx54-3278-m5g4, UBUNTU-CVE-2022-22976

## What is CVE-2022-22976?

CVE-2022-22976 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 19 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Security versions 5.5.x prior to 5.5.7, 5.6.x prior to 5.6.4, and earlier unsupported versions contain an integer overflow vulnerability. When using the BCrypt class with the maximum work factor (31), the encoder does not perform any salt rounds, due to an integer overflow error. The default settings are not affected by this CVE.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2022-22976?

4 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 5.2.0.RELEASE | 5.5.7 |
| `org.springframework.security:spring-security-core` | Maven | From 5.2.0.RELEASE | 5.5.7 |
| `org.springframework.security:spring-security-core` | Maven | From 5.6.0 | 5.6.4 |
| `org.springframework.security:spring-security-core` | Maven | From 5.6.0 | 5.6.4 |

Products: Netapp Active Iq Unified Manager, Oracle Financial Services Crime and Compliance Management Studio, Vmware Spring Security.

## How do I fix CVE-2022-22976?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 5.5.7 or 5.6.4.

## Is CVE-2022-22976 being exploited?

There is no known exploitation of CVE-2022-22976 in the wild and no public exploit code.

Public exploit code:

- https://github.com/spring-io/cve-2022-22976-bcrypt-skips-salt (github_poc): https://github.com/spring-io/cve-2022-22976-bcrypt-skips-salt

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22976 and fix it if it is affected.

What it is: CVE-2022-22976 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 19 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22976 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 5.2.0.RELEASE; fixed in 5.5.7
- org.springframework.security:spring-security-core (Maven): affected from 5.2.0.RELEASE; fixed in 5.5.7
- org.springframework.security:spring-security-core (Maven): affected from 5.6.0; fixed in 5.6.4
- org.springframework.security:spring-security-core (Maven): affected from 5.6.0; fixed in 5.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22976/ (Markdown: https://insights.sbomify.com/CVE-2022-22976/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22976
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22976
- OSV: https://osv.dev/vulnerability/CVE-2022-22976

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22976/
Summaries are generated and may contain mistakes; the official description above is the record.
