# CVE-2022-22978: Authorization bypass in Spring Security

> Attackers can bypass authorization checks in applications using Spring Security's RegexRequestMatcher with specific regex patterns.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hh32-7344-cg2f, ROOT-APP-MAVEN-CVE-2022-22978, UBUNTU-CVE-2022-22978

## What is CVE-2022-22978?

CVE-2022-22978 is a critical authentication bypass vulnerability in Netapp Active Iq Unified Manager, published on 19 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In spring security versions prior to 5.4.11+, 5.5.7+ , 5.6.4+ and older unsupported versions, RegexRequestMatcher can easily be misconfigured to be bypassed on some servlet containers. Applications using RegexRequestMatcher with `.` in the regular expression are possibly vulnerable to an authorization bypass.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-22978?

12 open source packages ship an affected version, including org.springframework.security:spring-security-core and org.springframework.security:spring-security-web. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | All versions | 5.4.11 |
| `org.springframework.security:spring-security-core` | Maven | All versions | 5.4.11 |
| `org.springframework.security:spring-security-core` | Maven | From 5.5.0 | 5.5.7 |
| `org.springframework.security:spring-security-core` | Maven | From 5.5.0 | 5.5.7 |
| `org.springframework.security:spring-security-core` | Maven | From 5.6.0 | 5.6.4 |
| `org.springframework.security:spring-security-core` | Maven | From 5.6.0 | 5.6.4 |
| `org.springframework.security:spring-security-web` | Maven | All versions | 5.4.11 |
| `org.springframework.security:spring-security-web` | Maven | All versions | 5.4.11 |
| `org.springframework.security:spring-security-web` | Maven | From 5.5.0 | 5.5.7 |
| `org.springframework.security:spring-security-web` | Maven | From 5.5.0 | 5.5.7 |
| `org.springframework.security:spring-security-web` | Maven | From 5.6.0 | 5.6.4 |
| `org.springframework.security:spring-security-web` | Maven | From 5.6.0 | 5.6.4 |

Products: Netapp Active Iq Unified Manager, Oracle Financial Services Crime and Compliance Management Studio, Vmware Spring Security.

## How do I fix CVE-2022-22978?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 5.4.11, 5.5.7 or 5.6.4.

## Is CVE-2022-22978 being exploited?

There is no known exploitation of CVE-2022-22978 in the wild and no public exploit code.

Public exploit code:

- CVE-2022-22978 Spring-Security bypass Demo (github_poc): https://github.com/DeEpinGh0st/CVE-2022-22978
- PoC of CVE-2022-22978 vulnerability in Spring Security framework (github_poc): https://github.com/ducluongtran9121/CVE-2022-22978-PoC
- CVE-2022-22978 POC Project (github_poc): https://github.com/aeifkz/CVE-2022-22978
- https://github.com/umakant76705/CVE-2022-22978 (github_poc): https://github.com/umakant76705/CVE-2022-22978
- https://github.com/Raghvendra1207/CVE-2022-22978 (github_poc): https://github.com/Raghvendra1207/CVE-2022-22978
- CVE-2022-22978漏洞实例代码 (github_poc): https://github.com/wan9xx/CVE-2022-22978-demo

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)
- [CVE-2018-2941](https://insights.sbomify.com/CVE-2018-2941/): Code injection in Java (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-22978 and fix it if it is affected.

What it is: CVE-2022-22978 is a critical authentication bypass vulnerability in Netapp Active Iq Unified Manager, published on 19 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-22978 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected all versions; fixed in 5.4.11
- org.springframework.security:spring-security-core (Maven): affected all versions; fixed in 5.4.11
- org.springframework.security:spring-security-core (Maven): affected from 5.5.0; fixed in 5.5.7
- org.springframework.security:spring-security-core (Maven): affected from 5.5.0; fixed in 5.5.7
- org.springframework.security:spring-security-core (Maven): affected from 5.6.0; fixed in 5.6.4
- org.springframework.security:spring-security-core (Maven): affected from 5.6.0; fixed in 5.6.4
- org.springframework.security:spring-security-web (Maven): affected all versions; fixed in 5.4.11
- org.springframework.security:spring-security-web (Maven): affected all versions; fixed in 5.4.11
- org.springframework.security:spring-security-web (Maven): affected from 5.5.0; fixed in 5.5.7
- org.springframework.security:spring-security-web (Maven): affected from 5.5.0; fixed in 5.5.7
- org.springframework.security:spring-security-web (Maven): affected from 5.6.0; fixed in 5.6.4
- org.springframework.security:spring-security-web (Maven): affected from 5.6.0; fixed in 5.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-22978/ (Markdown: https://insights.sbomify.com/CVE-2022-22978/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-22978
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-22978
- OSV: https://osv.dev/vulnerability/CVE-2022-22978

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-22978/
Summaries are generated and may contain mistakes; the official description above is the record.
