CVE-2022-22984 Command Injection
Attackers can execute arbitrary commands on the host system by passing crafted flags to the Snyk CLI when testing untrusted files.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-22984?
CVE-2022-22984 is a medium-severity command injection vulnerability in @snyk/snyk-cocoapods-plugin, published on 30 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The package snyk before 1.1064.0; the package snyk-mvn-plugin before 2.31.3; the package snyk-gradle-plugin before 3.24.5; the package @snyk/snyk-cocoapods-plugin before 2.5.3; the package snyk-sbt-plugin before 2.16.2; the package snyk-python-plugin before 1.24.2; the package snyk-docker-plugin before 5.6.5; the package @snyk/snyk-hex-plugin before 1.1.6 are vulnerable to Command Injection due to an incomplete fix for [CVE-2022-40764](https://security.snyk.io/vuln/SNYK-JS-SNYK-3037342). A successful exploit allows attackers to run arbitrary commands on the host system where the Snyk CLI is installed by passing in crafted command line flags. In order to exploit this vulnerability, a user would have to execute the snyk test command on untrusted files. In most cases, an attacker positioned to control the command line arguments to the Snyk CLI would already be positioned to execute arbitrary commands. However, this could be abused in specific scenarios, such as continuous integration pipelines, where developers can control the arguments passed to the Snyk CLI to leverage this component as part of a wider attack against an integration/build pipeline. This issue has been addressed in the latest Snyk Docker images available at https://hub.docker.com/r/snyk/snyk as of 2022-11-29. Images downloaded and built prior to that date should be updated. The issue has also been addressed in the Snyk TeamCity CI/CD plugin as of version v20221130.093605.
Weakness: CWE-78
Which versions are affected by CVE-2022-22984?
16 open source packages ship an affected version, including @snyk/snyk-cocoapods-plugin, @snyk/snyk-hex-plugin and snyk. It affects 8 products.
| Package | Affected | Fixed in |
|---|---|---|
@snyk/snyk-cocoapods-plugin npm | All versions | 2.5.3 |
@snyk/snyk-cocoapods-plugin npm | All versions | 2.5.3 |
@snyk/snyk-hex-plugin npm | All versions | 1.1.6 |
@snyk/snyk-hex-plugin npm | All versions | 1.1.6 |
snyk npm | All versions | 1.1064.0 |
snyk npm | All versions | 1.1064.0 |
10 more packages
snyk-docker-plugin npm | All versions | 5.6.5 |
snyk-docker-plugin npm | All versions | 5.6.5 |
snyk-gradle-plugin npm | All versions | 3.24.5 |
snyk-gradle-plugin npm | All versions | 3.24.5 |
snyk-mvn-plugin npm | All versions | 2.31.3 |
snyk-mvn-plugin npm | All versions | 2.31.3 |
snyk-python-plugin npm | All versions | 1.24.2 |
snyk-python-plugin npm | All versions | 1.24.2 |
snyk-sbt-plugin npm | All versions | 2.16.2 |
snyk-sbt-plugin npm | All versions | 2.16.2 |
Products include Snyk Snyk Cli, Snyk Snyk Cocoapods Cli, Snyk Snyk Docker Cli, Snyk Snyk Gradle Cli, Snyk Snyk Hex Cli, Snyk Snyk Maven Cli and 2 more.
How do I fix CVE-2022-22984?
Upgrade @snyk/snyk-cocoapods-plugin to 2.5.3 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2022-22984 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-22984 exists.
Other vulnerabilities in @snyk/snyk-cocoapods-plugin
Sources
Also known as GHSA-4x6g-3cmx-w76r.