{"answers":{"affected":"2 open source packages ship an affected version, including com.shopizer:shopizer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23059 in the wild and no public exploit code.","fix":"Upgrade com.shopizer:shopizer to 3.0.0 or later.","what":"CVE-2022-23059 is a medium-severity cross-site scripting vulnerability in shopizer-ecommerce Shopizer, published on 29 Mar 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23059 and fix it if it is affected.\n\nWhat it is: CVE-2022-23059 is a medium-severity cross-site scripting vulnerability in shopizer-ecommerce Shopizer, published on 29 Mar 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-23059 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.shopizer:shopizer (Maven): affected from 2.0.2; fixed in 3.0.0\n- com.shopizer:shopizer (Maven): affected from 2.0.2; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23059/ (Markdown: https://insights.sbomify.com/CVE-2022-23059/index.md)","id":"CVE-2022-23059","markdown":"https://insights.sbomify.com/CVE-2022-23059/index.md","name":"CVE-2022-23059","record":{"aliases":["GHSA-p2j7-6g9h-32xh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopizer e-commerce","requires_auth":"high_privilege","summary":"An attacker can inject malicious JavaScript via SVG uploads in the Manage Images tab, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mend","cpe":[{"product":"shopizer","vendor":"shopizer"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A Stored Cross Site Scripting (XSS) vulnerability exists in Shopizer versions 2.0 through 2.17.0 via the “Manage Images” tab, which allows an attacker to upload a SVG file containing malicious JavaScript code.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Shopizer - Stored XSS in Manage Images","id":"CVE-2022-23059","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Shopizer - Stored XSS in Manage Files","id":"CVE-2022-23060"},"packages":[{"ecosystem":"Maven","fixed":["3.0.0"],"introduced":["2.0.2"],"last_affected":[],"package":"com.shopizer:shopizer","purl":null,"source":"GHSA-p2j7-6g9h-32xh"},{"ecosystem":"Maven","fixed":["3.0.0"],"introduced":["2.0.2"],"last_affected":[],"package":"com.shopizer:shopizer","purl":"pkg:maven/com.shopizer/shopizer","source":"GHSA-p2j7-6g9h-32xh"}],"prev":{"headline":"ERPNext - Stored XSS in My Settings","id":"CVE-2022-23058"},"products":["Shopizer"],"published":"2022-03-29","related":[{"cvss_score":9.1,"headline":"Potential remote code execution in Shopizer","id":"CVE-2020-11006","kev_date_added":null,"published":"2020-05-08"},{"cvss_score":8.8,"headline":"Shopizer - Insufficient Session Expiration","id":"CVE-2022-23063","kev_date_added":null,"published":"2022-05-03"},{"cvss_score":8.1,"headline":"Security feature bypass in n/a","id":"CVE-2025-51605","kev_date_added":null,"published":"2025-08-22"},{"cvss_score":6.8,"headline":"Missing authorization in n/a","id":"CVE-2014-4963","kev_date_added":null,"published":"2014-07-15"},{"cvss_score":6.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2014-4964","kev_date_added":null,"published":"2014-07-15"},{"cvss_score":6.5,"headline":"Shopizer - IDOR delete superadmin","id":"CVE-2022-23061","kev_date_added":null,"published":"2022-05-01"},{"cvss_score":6.5,"headline":"Negative charge in shopping cart possible in Shopizer","id":"CVE-2020-11007","kev_date_added":null,"published":"2020-04-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["shopizer-ecommerce"]},"summary":"An attacker can inject malicious JavaScript via SVG uploads in the Manage Images tab, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2022-23059/"}