{"answers":{"affected":"2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23064 in the wild and no public exploit code.","fix":"Upgrade snipe/snipe-it to 5.3.8 or later.","what":"CVE-2022-23064 is a high-severity vulnerability in Snipeitapp Snipe-It, published on 2 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23064 and fix it if it is affected.\n\nWhat it is: CVE-2022-23064 is a high-severity vulnerability in Snipeitapp Snipe-It, published on 2 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-23064 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- snipe/snipe-it (Packagist): affected from 3.0-alpha; fixed in 5.3.8\n- snipe/snipe-it (Packagist): affected from 3.0-alpha; fixed in 5.3.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23064/ (Markdown: https://insights.sbomify.com/CVE-2022-23064/index.md)","id":"CVE-2022-23064","markdown":"https://insights.sbomify.com/CVE-2022-23064/index.md","name":"CVE-2022-23064","record":{"aliases":["GHSA-9vh6-qfv6-vcqp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"IT asset management","requires_auth":"none","summary":"Attackers can exploit Host Header Injection in password reset flows to leak tokens and take over user accounts in Snipe-IT.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mend","cpe":[{"product":"snipe-it","vendor":"snipeitapp"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"In Snipe-IT, versions v3.0-alpha to v5.3.7 are vulnerable to Host Header Injection. By sending a specially crafted host header in the reset password request, it is possible to send password reset links to users which once clicked lead to an attacker controlled server and thus leading to password reset token leak. This leads to account take over.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Snipe-IT - Host Header Injection","id":"CVE-2022-23064","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"snipeitapp:snipe-it","products":["snipeitapp:snipe-it"],"type":"open_redirect","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Vendure - XSS via SVG File Upload","id":"CVE-2022-23065"},"packages":[{"ecosystem":"Packagist","fixed":["5.3.8"],"introduced":["3.0-alpha"],"last_affected":[],"package":"snipe/snipe-it","purl":null,"source":"GHSA-9vh6-qfv6-vcqp"},{"ecosystem":"Packagist","fixed":["5.3.8"],"introduced":["3.0-alpha"],"last_affected":[],"package":"snipe/snipe-it","purl":"pkg:composer/snipe/snipe-it","source":"GHSA-9vh6-qfv6-vcqp"}],"prev":{"headline":"Shopizer - Insufficient Session Expiration","id":"CVE-2022-23063"},"products":["snipe-it"],"published":"2022-05-02","related":[{"cvss_score":9.9,"headline":"File upload in n/a","id":"CVE-2025-63601","kev_date_added":null,"published":"2025-11-05"},{"cvss_score":9.8,"headline":"Snipe-IT has insecure permissions in file uploads","id":"CVE-2026-37709","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":9.3,"headline":"Snipe-IT before 8.7.0 CSS Injection via Custom CSS","id":"CVE-2026-86738","kev_date_added":null,"published":"2026-09-08"},{"cvss_score":9.2,"headline":"Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback","id":"CVE-2026-116199","kev_date_added":null,"published":"2026-10-25"},{"cvss_score":9.1,"headline":"Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it","id":"CVE-2022-1380","kev_date_added":null,"published":"2022-04-16"},{"cvss_score":9,"headline":"Stored Cross Site Scripting vulnerability in the checked_out_to parameter in snipe/snipe-it","id":"CVE-2022-1445","kev_date_added":null,"published":"2022-04-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["snipe"]},"summary":"Attackers can exploit Host Header Injection in password reset flows to leak tokens and take over user accounts in Snipe-IT.","url":"https://insights.sbomify.com/CVE-2022-23064/"}