# CVE-2022-23064: Snipe-IT - Host Header Injection

> Attackers can exploit Host Header Injection in password reset flows to leak tokens and take over user accounts in Snipe-IT.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 May 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-9vh6-qfv6-vcqp

## What is CVE-2022-23064?

CVE-2022-23064 is a high-severity vulnerability in Snipeitapp Snipe-It, published on 2 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Snipe-IT, versions v3.0-alpha to v5.3.7 are vulnerable to Host Header Injection. By sending a specially crafted host header in the reset password request, it is possible to send password reset links to users which once clicked lead to an attacker controlled server and thus leading to password reset token leak. This leads to account take over.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-23064?

2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snipe/snipe-it` | Packagist | From 3.0-alpha | 5.3.8 |
| `snipe/snipe-it` | Packagist | From 3.0-alpha | 5.3.8 |

Products: Snipeitapp Snipe-It.

## How do I fix CVE-2022-23064?

Upgrade snipe/snipe-it to 5.3.8 or later.

## Is CVE-2022-23064 being exploited?

There is no known exploitation of CVE-2022-23064 in the wild and no public exploit code.

## Other vulnerabilities in Snipeitapp Snipe-It

- [CVE-2025-63601](https://insights.sbomify.com/CVE-2025-63601/): File upload in n/a (critical 9.9)
- [CVE-2026-37709](https://insights.sbomify.com/CVE-2026-37709/): Snipe-IT has insecure permissions in file uploads (critical 9.8)
- [CVE-2026-86738](https://insights.sbomify.com/CVE-2026-86738/): Snipe-IT before 8.7.0 CSS Injection via Custom CSS (critical 9.3)
- [CVE-2026-116199](https://insights.sbomify.com/CVE-2026-116199/): Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback (critical 9.2)
- [CVE-2022-1380](https://insights.sbomify.com/CVE-2022-1380/): Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23064 and fix it if it is affected.

What it is: CVE-2022-23064 is a high-severity vulnerability in Snipeitapp Snipe-It, published on 2 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23064 in the wild and no public exploit code.

Affected packages and fixed versions:
- snipe/snipe-it (Packagist): affected from 3.0-alpha; fixed in 5.3.8
- snipe/snipe-it (Packagist): affected from 3.0-alpha; fixed in 5.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23064/ (Markdown: https://insights.sbomify.com/CVE-2022-23064/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23064
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23064
- OSV: https://osv.dev/vulnerability/CVE-2022-23064

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23064/
Summaries are generated and may contain mistakes; the official description above is the record.
