CVE-2022-2307 Business logic in GitLab

Low 3.5 Published Updated

A malicious Group Owner can retain a usable Group Access Token after deleting the Group due to missing cascading deletes, bypassing intended access revocation.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-2307?

CVE-2022-2307 is a low-severity vulnerability in Gitlab Gitlab, published on 5 Aug 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A lack of cascading deletes in GitLab CE/EE affecting all versions starting from 13.0 before 15.0.5, all versions starting from 15.1 before 15.1.4, all versions starting from 15.2 before 15.2.1 allows a malicious Group Owner to retain a usable Group Access Token even after the Group is deleted, though the APIs usable by that token are limited.

Weakness: CWE-459

Which versions are affected by CVE-2022-2307?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.0.015.0.5, 15.1.4, 15.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2307?

Upgrade gitlab to a fixed version for your release line: 15.0.5, 15.1.4 or 15.2.1.

Is CVE-2022-2307 being exploited?

There is no known exploitation of CVE-2022-2307 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2307, GHSA-xpg3-c2hf-x9vf, UBUNTU-CVE-2022-2307.

Is CVE-2022-2307 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free