CVE-2022-23094 Libreswan 4.2 through 4.5 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted IKE
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2022-23094?
CVE-2022-23094 is a high-severity vulnerability in Debian Debian Linux, published on 15 Jan 2022.
Official description
Libreswan 4.2 through 4.5 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted IKEv1 packet because pluto/ikev1.c wrongly expects that a state object exists. This is fixed in 4.6.
Weakness: CWE-476
Which versions are affected by CVE-2022-23094?
It affects 3 products.
Linux distribution packages (8)
libreswan AlmaLinux:8 | All versions | 4.4-4.el8_5 |
libreswan Red Hat:enterprise_linux:8::appstream | All versions | 0:4.4-4.el8_5 |
libreswan-debuginfo Red Hat:enterprise_linux:8::appstream | All versions | 0:4.4-4.el8_5 |
libreswan-debugsource Red Hat:enterprise_linux:8::appstream | All versions | 0:4.4-4.el8_5 |
libreswan Red Hat:rhel_eus:8.4::appstream | All versions | 0:4.3-6.el8_4 |
libreswan-debuginfo Red Hat:rhel_eus:8.4::appstream | All versions | 0:4.3-6.el8_4 |
libreswan-debugsource Red Hat:rhel_eus:8.4::appstream | All versions | 0:4.3-6.el8_4 |
libreswan Rocky Linux:8 | All versions | 0:4.4-4.el8_5 |
Products include Debian Debian Linux, Fedoraproject Fedora, Libreswan Libreswan.
How do I fix CVE-2022-23094?
Upgrade to a fixed version.
Is CVE-2022-23094 being exploited?
There is no known exploitation of CVE-2022-23094 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALSA-2022:0199, DEBIAN-CVE-2022-23094, DSA-5048-1, GHSA-m3gq-3gw9-x3fv, MGASA-2022-0030, OESA-2022-1738 and 4 more.