# CVE-2022-23105: User passwords transmitted in plain text by Jenkins Active Directory Plugin

> Attackers can intercept unencrypted data between Jenkins and Active Directory servers, exposing sensitive information.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-c8cc-hj57-vm65

## What is CVE-2022-23105?

CVE-2022-23105 is a medium-severity vulnerability in Jenkins Active Directory Plugin, published on 12 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Jenkins Active Directory Plugin 2.25 and earlier does not encrypt the transmission of data between the Jenkins controller and Active Directory servers in most configurations.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2022-23105?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:active-directory. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:active-directory` | Maven | All versions | 2.25.1 |
| `org.jenkins-ci.plugins:active-directory` | Maven | All versions | 2.25.1 |

Products: Jenkins Active Directory.

## How do I fix CVE-2022-23105?

Upgrade org.jenkins-ci.plugins:active-directory to 2.25.1 or later.

## Is CVE-2022-23105 being exploited?

There is no known exploitation of CVE-2022-23105 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Active Directory Plugin

- [CVE-2020-2299](https://insights.sbomify.com/CVE-2020-2299/): Improper Authentication in Jenkins Active Directory Plugin (critical 9.8)
- [CVE-2020-2300](https://insights.sbomify.com/CVE-2020-2300/): Improper Authentication (empty password) in Jenkins Active Directory Plugin (critical 9.8)
- [CVE-2020-2301](https://insights.sbomify.com/CVE-2020-2301/): Authentication cache in Active Directory Jenkins Plugin allows logging in with any password (critical 9.8)
- [CVE-2017-2649](https://insights.sbomify.com/CVE-2017-2649/): Jenkins Active Directory Plugin did not verify certificate of AD server (high 8.1)
- [CVE-2019-1003009](https://insights.sbomify.com/CVE-2019-1003009/): Jenkins Active Directory Plugin Improper certificate validation with StartTLS (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23105 and fix it if it is affected.

What it is: CVE-2022-23105 is a medium-severity vulnerability in Jenkins Active Directory Plugin, published on 12 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23105 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:active-directory (Maven): affected all versions; fixed in 2.25.1
- org.jenkins-ci.plugins:active-directory (Maven): affected all versions; fixed in 2.25.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23105/ (Markdown: https://insights.sbomify.com/CVE-2022-23105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23105
- OSV: https://osv.dev/vulnerability/CVE-2022-23105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23105/
Summaries are generated and may contain mistakes; the official description above is the record.
