CVE-2022-23106 Observable Discrepancy and Observable Timing Discrepancy in Jenkins Configuration as Code Plugin
Attackers can bypass authentication token validation in the Jenkins Configuration as Code Plugin using timing attacks to obtain valid tokens.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-23106?
CVE-2022-23106 is a medium-severity vulnerability in Jenkins Configuration as Code Plugin, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Jenkins Configuration as Code Plugin 1.55 and earlier used a non-constant time comparison function when validating an authentication token allowing attackers to use statistical methods to obtain a valid authentication token.
Weakness: CWE-203
Which versions are affected by CVE-2022-23106?
8 open source packages ship an affected version, including io.jenkins:configuration-as-code. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.jenkins:configuration-as-code Maven | All versions | 1.47.1 |
io.jenkins:configuration-as-code Maven | All versions | 1.47.1 |
io.jenkins:configuration-as-code Maven | From 1.48 | 1.53.1 |
io.jenkins:configuration-as-code Maven | From 1.48 | 1.53.1 |
io.jenkins:configuration-as-code Maven | From 1.54 | 1.54.1 |
io.jenkins:configuration-as-code Maven | From 1.54 | 1.54.1 |
2 more packages
io.jenkins:configuration-as-code Maven | From 1.55 | 1.55.1 |
io.jenkins:configuration-as-code Maven | From 1.55 | 1.55.1 |
Products include Jenkins Configuration as Code.
How do I fix CVE-2022-23106?
Upgrade io.jenkins:configuration-as-code to a fixed version for your release line: 1.47.1, 1.53.1, 1.54.1 or 1.55.1.
Is CVE-2022-23106 being exploited?
There is no known exploitation of CVE-2022-23106 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Configuration as Code Plugin
- CVE-2018-1000610 Jenkins Configuration as Code Plugin has Insufficiently Protected Credentials
- CVE-2018-1000609 Jenkins Configuration as Code Plugin vulnerable to Exposure of Sensitive Information
- CVE-2019-10367 Insertion of Sensitive Information into Log File in Jenkins Configuration as Code Plugin
- CVE-2019-10345 Plaintext Storage of a Password in Jenkins Configuration as Code Plugin
- CVE-2019-10362 Improper Encoding or Escaping of Output in Jenkins Configuration as Code Plugin
Sources
Also known as GHSA-fpj7-9xm6-8hgr.