# CVE-2022-23106: Observable Discrepancy and Observable Timing Discrepancy in Jenkins Configuration as Code Plugin

> Attackers can bypass authentication token validation in the Jenkins Configuration as Code Plugin using timing attacks to obtain valid tokens.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-fpj7-9xm6-8hgr

## What is CVE-2022-23106?

CVE-2022-23106 is a medium-severity vulnerability in Jenkins Configuration as Code Plugin, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Configuration as Code Plugin 1.55 and earlier used a non-constant time comparison function when validating an authentication token allowing attackers to use statistical methods to obtain a valid authentication token.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2022-23106?

8 open source packages ship an affected version, including io.jenkins:configuration-as-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins:configuration-as-code` | Maven | All versions | 1.47.1 |
| `io.jenkins:configuration-as-code` | Maven | All versions | 1.47.1 |
| `io.jenkins:configuration-as-code` | Maven | From 1.48 | 1.53.1 |
| `io.jenkins:configuration-as-code` | Maven | From 1.48 | 1.53.1 |
| `io.jenkins:configuration-as-code` | Maven | From 1.54 | 1.54.1 |
| `io.jenkins:configuration-as-code` | Maven | From 1.54 | 1.54.1 |
| `io.jenkins:configuration-as-code` | Maven | From 1.55 | 1.55.1 |
| `io.jenkins:configuration-as-code` | Maven | From 1.55 | 1.55.1 |

Products: Jenkins Configuration as Code.

## How do I fix CVE-2022-23106?

Upgrade io.jenkins:configuration-as-code to a fixed version for your release line: 1.47.1, 1.53.1, 1.54.1 or 1.55.1.

## Is CVE-2022-23106 being exploited?

There is no known exploitation of CVE-2022-23106 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Configuration as Code Plugin

- [CVE-2018-1000610](https://insights.sbomify.com/CVE-2018-1000610/): Jenkins Configuration as Code Plugin has Insufficiently Protected Credentials (high 8.8)
- [CVE-2018-1000609](https://insights.sbomify.com/CVE-2018-1000609/): Jenkins Configuration as Code Plugin vulnerable to Exposure of Sensitive Information (medium 6.5)
- [CVE-2019-10367](https://insights.sbomify.com/CVE-2019-10367/): Insertion of Sensitive Information into Log File in Jenkins Configuration as Code Plugin (medium 5.5)
- [CVE-2019-10345](https://insights.sbomify.com/CVE-2019-10345/): Plaintext Storage of a Password in Jenkins Configuration as Code Plugin (medium 5.5)
- [CVE-2019-10362](https://insights.sbomify.com/CVE-2019-10362/): Improper Encoding or Escaping of Output in Jenkins Configuration as Code Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23106 and fix it if it is affected.

What it is: CVE-2022-23106 is a medium-severity vulnerability in Jenkins Configuration as Code Plugin, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23106 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins:configuration-as-code (Maven): affected all versions; fixed in 1.47.1
- io.jenkins:configuration-as-code (Maven): affected all versions; fixed in 1.47.1
- io.jenkins:configuration-as-code (Maven): affected from 1.48; fixed in 1.53.1
- io.jenkins:configuration-as-code (Maven): affected from 1.48; fixed in 1.53.1
- io.jenkins:configuration-as-code (Maven): affected from 1.54; fixed in 1.54.1
- io.jenkins:configuration-as-code (Maven): affected from 1.54; fixed in 1.54.1
- io.jenkins:configuration-as-code (Maven): affected from 1.55; fixed in 1.55.1
- io.jenkins:configuration-as-code (Maven): affected from 1.55; fixed in 1.55.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23106/ (Markdown: https://insights.sbomify.com/CVE-2022-23106/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23106
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23106
- OSV: https://osv.dev/vulnerability/CVE-2022-23106

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23106/
Summaries are generated and may contain mistakes; the official description above is the record.
