CVE-2022-23107 Path Traversal in Jenkins Warnings Next Generation Plugin
Attackers with configure permissions can read or write specific files on the Jenkins controller via unrestricted custom ID names.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-23107?
CVE-2022-23107 is a high-severity path traversal vulnerability in Jenkins Warnings Next Generation Plugin, published on 12 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system.
Weakness: CWE-22
Which versions are affected by CVE-2022-23107?
8 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.jenkins.plugins:warnings-ng Maven | All versions | 9.0.2 |
io.jenkins.plugins:warnings-ng Maven | All versions | 9.0.2 |
io.jenkins.plugins:warnings-ng Maven | From 9.1.0 | 9.5.2 |
io.jenkins.plugins:warnings-ng Maven | From 9.1.0 | 9.5.2 |
io.jenkins.plugins:warnings-ng Maven | From 9.6.0 | 9.7.1 |
io.jenkins.plugins:warnings-ng Maven | From 9.6.0 | 9.7.1 |
2 more packages
io.jenkins.plugins:warnings-ng Maven | From 9.8.0 | 9.10.3 |
io.jenkins.plugins:warnings-ng Maven | From 9.8.0 | 9.10.3 |
Products include Jenkins Warnings Next Generation.
How do I fix CVE-2022-23107?
Upgrade io.jenkins.plugins:warnings-ng to a fixed version for your release line: 9.0.2, 9.5.2, 9.7.1 or 9.10.3.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2022-23107 being exploited?
There is no known exploitation of CVE-2022-23107 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Warnings Next Generation Plugin
- CVE-2019-1003008 Jenkins Warnings Next Generation Plugin cross-site request forgery vulnerability
- CVE-2019-1003023 XSS vulnerability in Jenkins Warnings Next Generation Plugin
- CVE-2019-10325 Jenkins Warnings NG Plugin Cross-site scripting vulnerability
- CVE-2021-21626 Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents
- CVE-2019-10326 Jenkins Warnings NG Plugin cross-site request forgery vulnerability
Sources
Also known as GHSA-rvh4-g2rj-hr9c.