{"answers":{"affected":"8 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23107 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:warnings-ng to a fixed version for your release line: 9.0.2, 9.5.2, 9.7.1 or 9.10.3.","what":"CVE-2022-23107 is a high-severity path traversal vulnerability in Jenkins Warnings Next Generation Plugin, published on 12 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23107 and fix it if it is affected.\n\nWhat it is: CVE-2022-23107 is a high-severity path traversal vulnerability in Jenkins Warnings Next Generation Plugin, published on 12 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23107 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 9.0.2\n- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 9.0.2\n- io.jenkins.plugins:warnings-ng (Maven): affected from 9.1.0; fixed in 9.5.2\n- io.jenkins.plugins:warnings-ng (Maven): affected from 9.1.0; fixed in 9.5.2\n- io.jenkins.plugins:warnings-ng (Maven): affected from 9.6.0; fixed in 9.7.1\n- io.jenkins.plugins:warnings-ng (Maven): affected from 9.6.0; fixed in 9.7.1\n- io.jenkins.plugins:warnings-ng (Maven): affected from 9.8.0; fixed in 9.10.3\n- io.jenkins.plugins:warnings-ng (Maven): affected from 9.8.0; fixed in 9.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23107/ (Markdown: https://insights.sbomify.com/CVE-2022-23107/index.md)","id":"CVE-2022-23107","markdown":"https://insights.sbomify.com/CVE-2022-23107/index.md","name":"CVE-2022-23107","record":{"aliases":["GHSA-rvh4-g2rj-hr9c"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Attackers with configure permissions can read or write specific files on the Jenkins controller via unrestricted custom ID names.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"warnings_next_generation","vendor":"jenkins"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path Traversal in Jenkins Warnings Next Generation Plugin","id":"CVE-2022-23107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":8,"n_references":2,"next":{"headline":"Stored XSS vulnerability in Jenkins Badge Plugin","id":"CVE-2022-23108"},"packages":[{"ecosystem":"Maven","fixed":["9.0.2"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":null,"source":"GHSA-rvh4-g2rj-hr9c"},{"ecosystem":"Maven","fixed":["9.0.2"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":"pkg:maven/io.jenkins.plugins/warnings-ng","source":"GHSA-rvh4-g2rj-hr9c"},{"ecosystem":"Maven","fixed":["9.5.2"],"introduced":["9.1.0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":null,"source":"GHSA-rvh4-g2rj-hr9c"},{"ecosystem":"Maven","fixed":["9.5.2"],"introduced":["9.1.0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":"pkg:maven/io.jenkins.plugins/warnings-ng","source":"GHSA-rvh4-g2rj-hr9c"},{"ecosystem":"Maven","fixed":["9.7.1"],"introduced":["9.6.0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":null,"source":"GHSA-rvh4-g2rj-hr9c"},{"ecosystem":"Maven","fixed":["9.7.1"],"introduced":["9.6.0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":"pkg:maven/io.jenkins.plugins/warnings-ng","source":"GHSA-rvh4-g2rj-hr9c"},{"ecosystem":"Maven","fixed":["9.10.3"],"introduced":["9.8.0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":null,"source":"GHSA-rvh4-g2rj-hr9c"},{"ecosystem":"Maven","fixed":["9.10.3"],"introduced":["9.8.0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":"pkg:maven/io.jenkins.plugins/warnings-ng","source":"GHSA-rvh4-g2rj-hr9c"}],"prev":{"headline":"Observable Discrepancy and Observable Timing Discrepancy in Jenkins Configuration as Code Plugin","id":"CVE-2022-23106"},"products":["Jenkins Warnings Next Generation Plugin"],"published":"2022-01-12","related":[{"cvss_score":8.8,"headline":"Jenkins Warnings Next Generation Plugin cross-site request forgery vulnerability","id":"CVE-2019-1003008","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":6.1,"headline":"XSS vulnerability in Jenkins Warnings Next Generation Plugin","id":"CVE-2019-1003023","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":5.4,"headline":"Jenkins Warnings NG Plugin Cross-site scripting vulnerability","id":"CVE-2019-10325","kev_date_added":null,"published":"2019-05-31"},{"cvss_score":4.3,"headline":"Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents","id":"CVE-2021-21626","kev_date_added":null,"published":"2021-03-18"},{"cvss_score":4.3,"headline":"Jenkins Warnings NG Plugin cross-site request forgery vulnerability","id":"CVE-2019-10326","kev_date_added":null,"published":"2019-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with configure permissions can read or write specific files on the Jenkins controller via unrestricted custom ID names.","url":"https://insights.sbomify.com/CVE-2022-23107/"}