# CVE-2022-23107: Path Traversal in Jenkins Warnings Next Generation Plugin

> Attackers with configure permissions can read or write specific files on the Jenkins controller via unrestricted custom ID names.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rvh4-g2rj-hr9c

## What is CVE-2022-23107?

CVE-2022-23107 is a high-severity path traversal vulnerability in Jenkins Warnings Next Generation Plugin, published on 12 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-23107?

8 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:warnings-ng` | Maven | All versions | 9.0.2 |
| `io.jenkins.plugins:warnings-ng` | Maven | All versions | 9.0.2 |
| `io.jenkins.plugins:warnings-ng` | Maven | From 9.1.0 | 9.5.2 |
| `io.jenkins.plugins:warnings-ng` | Maven | From 9.1.0 | 9.5.2 |
| `io.jenkins.plugins:warnings-ng` | Maven | From 9.6.0 | 9.7.1 |
| `io.jenkins.plugins:warnings-ng` | Maven | From 9.6.0 | 9.7.1 |
| `io.jenkins.plugins:warnings-ng` | Maven | From 9.8.0 | 9.10.3 |
| `io.jenkins.plugins:warnings-ng` | Maven | From 9.8.0 | 9.10.3 |

Products: Jenkins Warnings Next Generation.

## How do I fix CVE-2022-23107?

Upgrade io.jenkins.plugins:warnings-ng to a fixed version for your release line: 9.0.2, 9.5.2, 9.7.1 or 9.10.3.

## Is CVE-2022-23107 being exploited?

There is no known exploitation of CVE-2022-23107 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Warnings Next Generation Plugin

- [CVE-2019-1003008](https://insights.sbomify.com/CVE-2019-1003008/): Jenkins Warnings Next Generation Plugin cross-site request forgery vulnerability (high 8.8)
- [CVE-2019-1003023](https://insights.sbomify.com/CVE-2019-1003023/): XSS vulnerability in Jenkins Warnings Next Generation Plugin (medium 6.1)
- [CVE-2019-10325](https://insights.sbomify.com/CVE-2019-10325/): Jenkins Warnings NG Plugin Cross-site scripting vulnerability (medium 5.4)
- [CVE-2021-21626](https://insights.sbomify.com/CVE-2021-21626/): Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents (medium 4.3)
- [CVE-2019-10326](https://insights.sbomify.com/CVE-2019-10326/): Jenkins Warnings NG Plugin cross-site request forgery vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23107 and fix it if it is affected.

What it is: CVE-2022-23107 is a high-severity path traversal vulnerability in Jenkins Warnings Next Generation Plugin, published on 12 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23107 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 9.0.2
- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 9.0.2
- io.jenkins.plugins:warnings-ng (Maven): affected from 9.1.0; fixed in 9.5.2
- io.jenkins.plugins:warnings-ng (Maven): affected from 9.1.0; fixed in 9.5.2
- io.jenkins.plugins:warnings-ng (Maven): affected from 9.6.0; fixed in 9.7.1
- io.jenkins.plugins:warnings-ng (Maven): affected from 9.6.0; fixed in 9.7.1
- io.jenkins.plugins:warnings-ng (Maven): affected from 9.8.0; fixed in 9.10.3
- io.jenkins.plugins:warnings-ng (Maven): affected from 9.8.0; fixed in 9.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23107/ (Markdown: https://insights.sbomify.com/CVE-2022-23107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23107
- OSV: https://osv.dev/vulnerability/CVE-2022-23107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23107/
Summaries are generated and may contain mistakes; the official description above is the record.
