# CVE-2022-23109: Improper credentials masking in Jenkins HashiCorp Vault Plugin

> Attackers can read Vault credentials from Jenkins build logs due to missing masking in the HashiCorp Vault plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-h6x7-jq46-fp33

## What is CVE-2022-23109?

CVE-2022-23109 is a medium-severity vulnerability in Jenkins HashiCorp Vault Plugin, published on 12 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins HashiCorp Vault Plugin 3.7.0 and earlier does not mask Vault credentials in Pipeline build logs or in Pipeline step descriptions when Pipeline: Groovy Plugin 2.85 or later is installed.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2022-23109?

2 open source packages ship an affected version, including com.datapipe.jenkins.plugins:hashicorp-vault-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.datapipe.jenkins.plugins:hashicorp-vault-plugin` | Maven | All versions | 3.8.0 |
| `com.datapipe.jenkins.plugins:hashicorp-vault-plugin` | Maven | All versions | 3.8.0 |

Products: Jenkins Hashicorp Vault.

## How do I fix CVE-2022-23109?

Upgrade com.datapipe.jenkins.plugins:hashicorp-vault-plugin to 3.8.0 or later.

## Is CVE-2022-23109 being exploited?

There is no known exploitation of CVE-2022-23109 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins HashiCorp Vault Plugin

- [CVE-2023-33001](https://insights.sbomify.com/CVE-2023-33001/): Jenkins HashiCorp Vault Plugin has improper masking of credentials (high 7.5)
- [CVE-2022-36888](https://insights.sbomify.com/CVE-2022-36888/): Jenkins HashiCorp Vault Plugin does not perform permission checks in several HTTP endpoints that perform Vault connection tests (medium 6.5)
- [CVE-2022-25186](https://insights.sbomify.com/CVE-2022-25186/): Agent-to-controller security bypass in Jenkins HashiCorp Vault Plugin (medium 6.5)
- [CVE-2022-25197](https://insights.sbomify.com/CVE-2022-25197/): Agent-to-controller security bypass in Jenkins HashiCorp Vault Plugin allows reading arbitrary files (medium 6.5)
- [CVE-2025-67642](https://insights.sbomify.com/CVE-2025-67642/): Jenkins HashiCorp Vault Plugin exposes system-scoped Vault credentials (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23109 and fix it if it is affected.

What it is: CVE-2022-23109 is a medium-severity vulnerability in Jenkins HashiCorp Vault Plugin, published on 12 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23109 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.datapipe.jenkins.plugins:hashicorp-vault-plugin (Maven): affected all versions; fixed in 3.8.0
- com.datapipe.jenkins.plugins:hashicorp-vault-plugin (Maven): affected all versions; fixed in 3.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23109/ (Markdown: https://insights.sbomify.com/CVE-2022-23109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23109
- OSV: https://osv.dev/vulnerability/CVE-2022-23109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23109/
Summaries are generated and may contain mistakes; the official description above is the record.
