{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:publish-over-ssh. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23110 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:publish-over-ssh to 1.23 or later.","what":"CVE-2022-23110 is a medium-severity cross-site scripting vulnerability in Jenkins Publish Over SSH Plugin, published on 12 Jan 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23110 and fix it if it is affected.\n\nWhat it is: CVE-2022-23110 is a medium-severity cross-site scripting vulnerability in Jenkins Publish Over SSH Plugin, published on 12 Jan 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-23110 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:publish-over-ssh (Maven): affected all versions; fixed in 1.23\n- org.jenkins-ci.plugins:publish-over-ssh (Maven): affected all versions; fixed in 1.23\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23110/ (Markdown: https://insights.sbomify.com/CVE-2022-23110/index.md)","id":"CVE-2022-23110","markdown":"https://insights.sbomify.com/CVE-2022-23110/index.md","name":"CVE-2022-23110","record":{"aliases":["GHSA-fjpm-hf7c-xgc2"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins SSH plugin","requires_auth":"high_privilege","summary":"Stored XSS in Jenkins Publish Over SSH Plugin allows attackers with admin permissions to execute scripts, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"publish_over_ssh","vendor":"jenkins"}],"cvss":{"score":4.8,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Publish Over SSH Plugin 1.22 and earlier does not escape the SSH server name, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Overall/Administer permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS vulnerability in Jenkins Publish Over SSH Plugin","id":"CVE-2022-23110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"CSRF vulnerability and missing permission checks in Jenkins Publish Over SSH Plugin","id":"CVE-2022-23111"},"packages":[{"ecosystem":"Maven","fixed":["1.23"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:publish-over-ssh","purl":null,"source":"GHSA-fjpm-hf7c-xgc2"},{"ecosystem":"Maven","fixed":["1.23"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:publish-over-ssh","purl":"pkg:maven/org.jenkins-ci.plugins/publish-over-ssh","source":"GHSA-fjpm-hf7c-xgc2"}],"prev":{"headline":"Improper credentials masking in Jenkins HashiCorp Vault Plugin","id":"CVE-2022-23109"},"products":["Jenkins Publish Over SSH Plugin"],"published":"2022-01-12","related":[{"cvss_score":6.5,"headline":"Missing permission check in Jenkins Publish Over SSH Plugin","id":"CVE-2022-23112","kev_date_added":null,"published":"2022-01-12"},{"cvss_score":4.3,"headline":"CSRF vulnerability and missing permission checks in Jenkins Publish Over SSH Plugin","id":"CVE-2022-23111","kev_date_added":null,"published":"2022-01-12"},{"cvss_score":4.3,"headline":"Path traversal vulnerability in Jenkins Publish Over SSH Plugin","id":"CVE-2022-23113","kev_date_added":null,"published":"2022-01-12"},{"cvss_score":3.3,"headline":"Password stored in plain text by Jenkins Publish Over SSH Plugin","id":"CVE-2022-23114","kev_date_added":null,"published":"2022-01-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Publish Over SSH Plugin allows attackers with admin permissions to execute scripts, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2022-23110/"}