# CVE-2022-23110: Stored XSS vulnerability in Jenkins Publish Over SSH Plugin

> Stored XSS in Jenkins Publish Over SSH Plugin allows attackers with admin permissions to execute scripts, potentially leading to account takeover.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-fjpm-hf7c-xgc2

## What is CVE-2022-23110?

CVE-2022-23110 is a medium-severity cross-site scripting vulnerability in Jenkins Publish Over SSH Plugin, published on 12 Jan 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Jenkins Publish Over SSH Plugin 1.22 and earlier does not escape the SSH server name, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Overall/Administer permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23110?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:publish-over-ssh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:publish-over-ssh` | Maven | All versions | 1.23 |
| `org.jenkins-ci.plugins:publish-over-ssh` | Maven | All versions | 1.23 |

Products: Jenkins Publish Over Ssh.

## How do I fix CVE-2022-23110?

Upgrade org.jenkins-ci.plugins:publish-over-ssh to 1.23 or later.

## Is CVE-2022-23110 being exploited?

There is no known exploitation of CVE-2022-23110 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Publish Over SSH Plugin

- [CVE-2022-23112](https://insights.sbomify.com/CVE-2022-23112/): Missing permission check in Jenkins Publish Over SSH Plugin (medium 6.5)
- [CVE-2022-23111](https://insights.sbomify.com/CVE-2022-23111/): CSRF vulnerability and missing permission checks in Jenkins Publish Over SSH Plugin (medium 4.3)
- [CVE-2022-23113](https://insights.sbomify.com/CVE-2022-23113/): Path traversal vulnerability in Jenkins Publish Over SSH Plugin (medium 4.3)
- [CVE-2022-23114](https://insights.sbomify.com/CVE-2022-23114/): Password stored in plain text by Jenkins Publish Over SSH Plugin (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23110 and fix it if it is affected.

What it is: CVE-2022-23110 is a medium-severity cross-site scripting vulnerability in Jenkins Publish Over SSH Plugin, published on 12 Jan 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23110 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:publish-over-ssh (Maven): affected all versions; fixed in 1.23
- org.jenkins-ci.plugins:publish-over-ssh (Maven): affected all versions; fixed in 1.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23110/ (Markdown: https://insights.sbomify.com/CVE-2022-23110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23110
- OSV: https://osv.dev/vulnerability/CVE-2022-23110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23110/
Summaries are generated and may contain mistakes; the official description above is the record.
