# CVE-2022-23111: CSRF vulnerability and missing permission checks in Jenkins Publish Over SSH Plugin

> Attackers can force users to connect to malicious SSH servers with attacker-controlled credentials via CSRF in the Jenkins Publish Over SSH plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-884c-9wwh-9p6v

## What is CVE-2022-23111?

CVE-2022-23111 is a medium-severity vulnerability in Jenkins Publish Over SSH Plugin, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins Publish Over SSH Plugin 1.22 and earlier allows attackers to connect to an attacker-specified SSH server using attacker-specified credentials.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-23111?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:publish-over-ssh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:publish-over-ssh` | Maven | All versions | 1.23 |
| `org.jenkins-ci.plugins:publish-over-ssh` | Maven | All versions | 1.23 |

Products: Jenkins Publish Over Ssh.

## How do I fix CVE-2022-23111?

Upgrade org.jenkins-ci.plugins:publish-over-ssh to 1.23 or later.

## Is CVE-2022-23111 being exploited?

There is no known exploitation of CVE-2022-23111 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Publish Over SSH Plugin

- [CVE-2022-23112](https://insights.sbomify.com/CVE-2022-23112/): Missing permission check in Jenkins Publish Over SSH Plugin (medium 6.5)
- [CVE-2022-23110](https://insights.sbomify.com/CVE-2022-23110/): Stored XSS vulnerability in Jenkins Publish Over SSH Plugin (medium 4.8)
- [CVE-2022-23113](https://insights.sbomify.com/CVE-2022-23113/): Path traversal vulnerability in Jenkins Publish Over SSH Plugin (medium 4.3)
- [CVE-2022-23114](https://insights.sbomify.com/CVE-2022-23114/): Password stored in plain text by Jenkins Publish Over SSH Plugin (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23111 and fix it if it is affected.

What it is: CVE-2022-23111 is a medium-severity vulnerability in Jenkins Publish Over SSH Plugin, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23111 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:publish-over-ssh (Maven): affected all versions; fixed in 1.23
- org.jenkins-ci.plugins:publish-over-ssh (Maven): affected all versions; fixed in 1.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23111/ (Markdown: https://insights.sbomify.com/CVE-2022-23111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23111
- OSV: https://osv.dev/vulnerability/CVE-2022-23111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23111/
Summaries are generated and may contain mistakes; the official description above is the record.
