# CVE-2022-23113: Path traversal vulnerability in Jenkins Publish Over SSH Plugin

> Attackers with Item/Configure permission can discover Jenkins controller file names via path traversal in the Publish Over SSH plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 15 Oct 2024
- **Also known as:** GHSA-j8rg-4hjm-8r95

## What is CVE-2022-23113?

CVE-2022-23113 is a medium-severity path traversal vulnerability in Jenkins Publish Over SSH Plugin, published on 12 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Publish Over SSH Plugin 1.22 and earlier performs a validation of the file name specifying whether it is present or not, resulting in a path traversal vulnerability allowing attackers with Item/Configure permission to discover the name of the Jenkins controller files.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-23113?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:publish-over-ssh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:publish-over-ssh` | Maven | All versions | 1.23 |
| `org.jenkins-ci.plugins:publish-over-ssh` | Maven | All versions | 1.23 |

Products: Jenkins Publish Over Ssh.

## How do I fix CVE-2022-23113?

Upgrade org.jenkins-ci.plugins:publish-over-ssh to 1.23 or later.

## Is CVE-2022-23113 being exploited?

There is no known exploitation of CVE-2022-23113 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Publish Over SSH Plugin

- [CVE-2022-23112](https://insights.sbomify.com/CVE-2022-23112/): Missing permission check in Jenkins Publish Over SSH Plugin (medium 6.5)
- [CVE-2022-23110](https://insights.sbomify.com/CVE-2022-23110/): Stored XSS vulnerability in Jenkins Publish Over SSH Plugin (medium 4.8)
- [CVE-2022-23111](https://insights.sbomify.com/CVE-2022-23111/): CSRF vulnerability and missing permission checks in Jenkins Publish Over SSH Plugin (medium 4.3)
- [CVE-2022-23114](https://insights.sbomify.com/CVE-2022-23114/): Password stored in plain text by Jenkins Publish Over SSH Plugin (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23113 and fix it if it is affected.

What it is: CVE-2022-23113 is a medium-severity path traversal vulnerability in Jenkins Publish Over SSH Plugin, published on 12 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23113 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:publish-over-ssh (Maven): affected all versions; fixed in 1.23
- org.jenkins-ci.plugins:publish-over-ssh (Maven): affected all versions; fixed in 1.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23113/ (Markdown: https://insights.sbomify.com/CVE-2022-23113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23113
- OSV: https://osv.dev/vulnerability/CVE-2022-23113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23113/
Summaries are generated and may contain mistakes; the official description above is the record.
